airflow-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Brooke (JIRA)" <j...@apache.org>
Subject [jira] [Created] (AIRFLOW-3224) Flask Errors when Installing Airflow 1.10 in Kubernetes
Date Wed, 17 Oct 2018 12:39:00 GMT
Brooke created AIRFLOW-3224:
-------------------------------

             Summary: Flask Errors when Installing Airflow 1.10 in Kubernetes
                 Key: AIRFLOW-3224
                 URL: https://issues.apache.org/jira/browse/AIRFLOW-3224
             Project: Apache Airflow
          Issue Type: Bug
          Components: celery, dependencies, kubernetes, scheduler, webapp
    Affects Versions: 1.10.0
            Reporter: Brooke


I am currently working on deploying Apache Airflow 1.10.0 to a Kubernetes cluster. I am running
into some dependency issues with Flask.
If I use the current version of flask-login (0.4.1), I receive this error:
{{apache-airflow 1.10.0 has requirement flask-login==0.2.11, but you'll have flask-login 0.4.1
which is incompatible.}}
With this error, the UI won't render, and instead, I see a text bomb followed by many flask-appbuilder/flask-login
warnings.

If I use the Airflow's requirement of flask-login (0.2.11), I receive this error:

{{flask-appbuilder 1.12.0 has requirement Flask-Login<0.5,>=0.3, but you'll have flask-login
0.2.11 which is incompatible.}}
With this error, the UI renders with Airflow 1.9 features and CeleryExecutor won't work.



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

Mime
View raw message