airflow-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Kevin Campbell (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (AIRFLOW-2691) Make Airflow's JS code (and dependencies) manageable via npm and webpack
Date Thu, 26 Jul 2018 04:09:00 GMT

    [ https://issues.apache.org/jira/browse/AIRFLOW-2691?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16556870#comment-16556870
] 

Kevin Campbell commented on AIRFLOW-2691:
-----------------------------------------

This breaks airflow installation when installing master via pip
{code:java}
pip install -e git+https://github.com/apache/incubator-airflow.git#egg=apache-airflow[postgres]
{code}
For users who are working from a git checkout, they would need to apply the npm commands in
CONTRIBUTING.md if they are using RBAC. There probably needs to be something in UPDATING.md
? 

> Make Airflow's JS code (and dependencies) manageable via npm and webpack
> ------------------------------------------------------------------------
>
>                 Key: AIRFLOW-2691
>                 URL: https://issues.apache.org/jira/browse/AIRFLOW-2691
>             Project: Apache Airflow
>          Issue Type: New Feature
>            Reporter: Verdan Mahmood
>            Assignee: Verdan Mahmood
>            Priority: Major
>             Fix For: 2.0.0
>
>
> Airflow's JS code is hard to maintain and upgrade. The dependencies are locally existing
files making it hard to upgrade versions. 
> Make sure Airflow uses *npm* and *webpack* for the dependencies management. 



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

Mime
View raw message