airflow-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Fokko Driesprong (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (AIRFLOW-2489) Update Python dependencies
Date Fri, 18 May 2018 12:32:00 GMT

     [ https://issues.apache.org/jira/browse/AIRFLOW-2489?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Fokko Driesprong updated AIRFLOW-2489:
--------------------------------------
    Description: 
Right now it might take a while to update the dependencies. And we would like to update the
dependencies to make sure that we don't have any version conflicts like:
Traceback (most recent call last):
  File "/home/travis/build/Fokko/incubator-airflow/.tox/py27-backend_postgres/bin/airflow",
line 4, in <module>
    __import__('pkg_resources').require('apache-airflow==2.0.0.dev0+incubating')
  File "/home/travis/build/Fokko/incubator-airflow/.tox/py27-backend_postgres/lib/python2.7/site-packages/pkg_resources/__init__.py",
line 3086, in <module>
    @_call_aside
  File "/home/travis/build/Fokko/incubator-airflow/.tox/py27-backend_postgres/lib/python2.7/site-packages/pkg_resources/__init__.py",
line 3070, in _call_aside
    f(*args, **kwargs)
  File "/home/travis/build/Fokko/incubator-airflow/.tox/py27-backend_postgres/lib/python2.7/site-packages/pkg_resources/__init__.py",
line 3099, in _initialize_master_working_set
    working_set = WorkingSet._build_master()
  File "/home/travis/build/Fokko/incubator-airflow/.tox/py27-backend_postgres/lib/python2.7/site-packages/pkg_resources/__init__.py",
line 576, in _build_master
    return cls._build_from_requirements(__requires__)
  File "/home/travis/build/Fokko/incubator-airflow/.tox/py27-backend_postgres/lib/python2.7/site-packages/pkg_resources/__init__.py",
line 589, in _build_from_requirements
    dists = ws.resolve(reqs, Environment())
  File "/home/travis/build/Fokko/incubator-airflow/.tox/py27-backend_postgres/lib/python2.7/site-packages/pkg_resources/__init__.py",
line 783, in resolve
    raise VersionConflict(dist, req).with_context(dependent_req)
pkg_resources.ContextualVersionConflict: (Flask 0.12.4 (/home/travis/build/Fokko/incubator-airflow/.tox/py27-backend_postgres/lib/python2.7/site-packages),
Requirement.parse('Flask<0.12.2,>=0.10.0'), set(['flask-appbuilder']))


  was:
Currently there is a conflict:
Traceback (most recent call last):
  File "/home/travis/build/Fokko/incubator-airflow/.tox/py27-backend_postgres/bin/airflow",
line 4, in <module>
    __import__('pkg_resources').require('apache-airflow==2.0.0.dev0+incubating')
  File "/home/travis/build/Fokko/incubator-airflow/.tox/py27-backend_postgres/lib/python2.7/site-packages/pkg_resources/__init__.py",
line 3086, in <module>
    @_call_aside
  File "/home/travis/build/Fokko/incubator-airflow/.tox/py27-backend_postgres/lib/python2.7/site-packages/pkg_resources/__init__.py",
line 3070, in _call_aside
    f(*args, **kwargs)
  File "/home/travis/build/Fokko/incubator-airflow/.tox/py27-backend_postgres/lib/python2.7/site-packages/pkg_resources/__init__.py",
line 3099, in _initialize_master_working_set
    working_set = WorkingSet._build_master()
  File "/home/travis/build/Fokko/incubator-airflow/.tox/py27-backend_postgres/lib/python2.7/site-packages/pkg_resources/__init__.py",
line 576, in _build_master
    return cls._build_from_requirements(__requires__)
  File "/home/travis/build/Fokko/incubator-airflow/.tox/py27-backend_postgres/lib/python2.7/site-packages/pkg_resources/__init__.py",
line 589, in _build_from_requirements
    dists = ws.resolve(reqs, Environment())
  File "/home/travis/build/Fokko/incubator-airflow/.tox/py27-backend_postgres/lib/python2.7/site-packages/pkg_resources/__init__.py",
line 783, in resolve
    raise VersionConflict(dist, req).with_context(dependent_req)
pkg_resources.ContextualVersionConflict: (Flask 0.12.4 (/home/travis/build/Fokko/incubator-airflow/.tox/py27-backend_postgres/lib/python2.7/site-packages),
Requirement.parse('Flask<0.12.2,>=0.10.0'), set(['flask-appbuilder']))



> Update Python dependencies
> --------------------------
>
>                 Key: AIRFLOW-2489
>                 URL: https://issues.apache.org/jira/browse/AIRFLOW-2489
>             Project: Apache Airflow
>          Issue Type: Improvement
>            Reporter: Fokko Driesprong
>            Priority: Major
>
> Right now it might take a while to update the dependencies. And we would like to update
the dependencies to make sure that we don't have any version conflicts like:
> Traceback (most recent call last):
>   File "/home/travis/build/Fokko/incubator-airflow/.tox/py27-backend_postgres/bin/airflow",
line 4, in <module>
>     __import__('pkg_resources').require('apache-airflow==2.0.0.dev0+incubating')
>   File "/home/travis/build/Fokko/incubator-airflow/.tox/py27-backend_postgres/lib/python2.7/site-packages/pkg_resources/__init__.py",
line 3086, in <module>
>     @_call_aside
>   File "/home/travis/build/Fokko/incubator-airflow/.tox/py27-backend_postgres/lib/python2.7/site-packages/pkg_resources/__init__.py",
line 3070, in _call_aside
>     f(*args, **kwargs)
>   File "/home/travis/build/Fokko/incubator-airflow/.tox/py27-backend_postgres/lib/python2.7/site-packages/pkg_resources/__init__.py",
line 3099, in _initialize_master_working_set
>     working_set = WorkingSet._build_master()
>   File "/home/travis/build/Fokko/incubator-airflow/.tox/py27-backend_postgres/lib/python2.7/site-packages/pkg_resources/__init__.py",
line 576, in _build_master
>     return cls._build_from_requirements(__requires__)
>   File "/home/travis/build/Fokko/incubator-airflow/.tox/py27-backend_postgres/lib/python2.7/site-packages/pkg_resources/__init__.py",
line 589, in _build_from_requirements
>     dists = ws.resolve(reqs, Environment())
>   File "/home/travis/build/Fokko/incubator-airflow/.tox/py27-backend_postgres/lib/python2.7/site-packages/pkg_resources/__init__.py",
line 783, in resolve
>     raise VersionConflict(dist, req).with_context(dependent_req)
> pkg_resources.ContextualVersionConflict: (Flask 0.12.4 (/home/travis/build/Fokko/incubator-airflow/.tox/py27-backend_postgres/lib/python2.7/site-packages),
Requirement.parse('Flask<0.12.2,>=0.10.0'), set(['flask-appbuilder']))



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

Mime
View raw message