airflow-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Simon Hellbe (JIRA)" <j...@apache.org>
Subject [jira] [Created] (AIRFLOW-2343) pip gcp_api dependency conflicts
Date Thu, 19 Apr 2018 02:53:00 GMT
Simon Hellbe created AIRFLOW-2343:
-------------------------------------

             Summary: pip gcp_api dependency conflicts
                 Key: AIRFLOW-2343
                 URL: https://issues.apache.org/jira/browse/AIRFLOW-2343
             Project: Apache Airflow
          Issue Type: Bug
          Components: dependencies
    Affects Versions: Airflow 1.9.0
         Environment: Ubuntu Server 17.10
Debian 9
            Reporter: Simon Hellbe


In a clean virtualenv with python 2.7 on Ubuntu:
{code:java}
pip install apache-airflow[gcp_api]{code}
Fails with downstream dependency conflicts for the installed versions of google-cloud-bigquery
and google-cloud-pubsub. Have tried installing various versions of the packages but can't
find a compatible combination.
{code:java}
google-cloud-pubsub 0.26.0 has requirement google-cloud-core<0.26dev,>=0.25.0, but you'll
have google-cloud-core 0.28.1 which is incompatible.apache-beam 2.4.0 has requirement dill==0.2.6,
but you'll have dill 0.2.7.1 which is incompatible.apache-beam 2.4.0 has requirement httplib2<0.10,>=0.8,
but you'll have httplib2 0.11.3 which is incompatible.googledatastore 7.0.1 has requirement
httplib2<0.10,>=0.9.1, but you'll have httplib2 0.11.3 which is incompatible.{code}



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

Mime
View raw message