airflow-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "David Klosowski (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (AIRFLOW-2272) Travis CI is failing builds due to oracle-java8-installer failing to install via apt-get
Date Mon, 02 Apr 2018 18:54:00 GMT

    [ https://issues.apache.org/jira/browse/AIRFLOW-2272?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16422970#comment-16422970
] 

David Klosowski commented on AIRFLOW-2272:
------------------------------------------

OK, everything succeeded besides flake8.  Wondering if this is still an issue or if jdk9
works and not jdk8.

> Travis CI is failing builds due to oracle-java8-installer failing to install via apt-get
> ----------------------------------------------------------------------------------------
>
>                 Key: AIRFLOW-2272
>                 URL: https://issues.apache.org/jira/browse/AIRFLOW-2272
>             Project: Apache Airflow
>          Issue Type: Bug
>          Components: ci
>            Reporter: David Klosowski
>            Priority: Critical
>              Labels: build-failure
>
> All the PR builds in TravisCI are failing with the following apt-get error:
>  
> {code:java}
> --2018-03-30 17:56:23-- (try: 5) http://download.oracle.com/otn-pub/java/jdk/8u161-b12/2f38c3b165be4555a1fa6e98c45e0808/jdk-8u161-linux-x64.tar.gz
> Connecting to download.oracle.com (download.oracle.com)|23.45.144.164|:80... failed:
Connection timed out.
> Giving up.
> apt-get install failed
> $ cat ~/apt-get-update.log
> Ign:1 http://us-central1.gce.archive.ubuntu.com/ubuntu trusty InRelease
> Hit:2 http://us-central1.gce.archive.ubuntu.com/ubuntu trusty-updates InRelease
> Hit:3 http://us-central1.gce.archive.ubuntu.com/ubuntu trusty-backports InRelease
> Hit:4 http://us-central1.gce.archive.ubuntu.com/ubuntu trusty Release
> Ign:5 http://repo.mongodb.org/apt/ubuntu trusty/mongodb-org/3.4 InRelease
> Ign:6 http://dl.google.com/linux/chrome/deb stable InRelease
> Hit:7 http://repo.mongodb.org/apt/ubuntu trusty/mongodb-org/3.4 Release
> Hit:8 http://security.ubuntu.com/ubuntu trusty-security InRelease
> Ign:9 http://toolbelt.heroku.com/ubuntu ./ InRelease
> Get:10 http://dl.bintray.com/apache/cassandra 39x InRelease [3,168 B]
> Hit:11 http://ppa.launchpad.net/chris-lea/redis-server/ubuntu trusty InRelease
> Hit:13 https://download.docker.com/linux/ubuntu trusty InRelease
> Hit:12 http://toolbelt.heroku.com/ubuntu ./ Release
> Hit:15 http://dl.google.com/linux/chrome/deb stable Release
> Hit:16 http://apt.postgresql.org/pub/repos/apt trusty-pgdg InRelease
> Hit:18 https://dl.hhvm.com/ubuntu trusty InRelease
> Ign:19 http://ppa.launchpad.net/couchdb/stable/ubuntu trusty InRelease
> Hit:22 https://packagecloud.io/computology/apt-backport/ubuntu trusty InRelease
> Hit:23 https://packagecloud.io/github/git-lfs/ubuntu trusty InRelease
> Hit:24 https://packagecloud.io/rabbitmq/rabbitmq-server/ubuntu trusty InRelease
> Hit:25 http://ppa.launchpad.net/git-core/ppa/ubuntu trusty InRelease
> Hit:26 http://ppa.launchpad.net/openjdk-r/ppa/ubuntu trusty InRelease
> Hit:27 http://ppa.launchpad.net/pollinate/ppa/ubuntu trusty InRelease
> Hit:28 http://ppa.launchpad.net/webupd8team/java/ubuntu trusty InRelease
> Hit:29 http://ppa.launchpad.net/couchdb/stable/ubuntu trusty Release
> Fetched 3,168 B in 2s (1,102 B/s)
> Reading package lists...
> W: http://ppa.launchpad.net/couchdb/stable/ubuntu/dists/trusty/Release.gpg: Signature
by key 15866BAFD9BCC4F3C1E0DFC7D69548E1C17EAB57 uses weak digest algorithm (SHA1)
>  
> The command "sudo -E apt-get -yq --no-install-suggests --no-install-recommends --force-yes
install slapd ldap-utils openssh-server mysql-server-5.6 mysql-client-core-5.6 mysql-client-5.6
krb5-user krb5-kdc krb5-admin-server oracle-java8-installer python-selinux" failed and exited
with 100 during .{code}
>  
>  It looks like this is due to the configuration in the .travis.yml installing {{oracle-java8-installer}}:
> {code}
>   apt:
>     packages:
>       - slapd
>       - ldap-utils
>       - openssh-server
>       - mysql-server-5.6
>       - mysql-client-core-5.6
>       - mysql-client-5.6
>       - krb5-user
>       - krb5-kdc
>       - krb5-admin-server
>       - oracle-java8-installer
>       - python-selinux
> {code}
>  



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

Mime
View raw message