airflow-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Ash Berlin-Taylor (JIRA)" <j...@apache.org>
Subject [jira] [Resolved] (AIRFLOW-1966) Password authentication setup broken by SqlAlchemy version 1.2
Date Sat, 10 Mar 2018 10:42:00 GMT

     [ https://issues.apache.org/jira/browse/AIRFLOW-1966?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Ash Berlin-Taylor resolved AIRFLOW-1966.
----------------------------------------
       Resolution: Fixed
    Fix Version/s: 1.9.1
                   1.10.0

> Password authentication setup broken by SqlAlchemy version 1.2 
> ---------------------------------------------------------------
>
>                 Key: AIRFLOW-1966
>                 URL: https://issues.apache.org/jira/browse/AIRFLOW-1966
>             Project: Apache Airflow
>          Issue Type: Bug
>          Components: authentication
>    Affects Versions: 1.8.1, 1.8.0, 1.9.0, 1.9.1
>            Reporter: Daniel Thomas
>            Priority: Major
>             Fix For: 1.10.0, 1.9.1
>
>
> An update of SqlAlchemy to version 1.2 broke the authentication setup as described in
the [docs | https://airflow.apache.org/security.html].
> Setting the password failed with an exception "AttributeError: can't set attribute".
> This is was due to Airflow not settings a specific version requirement on SqlAlchemy.
This is fixed in master. But this is not sufficient, as this breaks every new deployment of
older version for user using Airflow in Docker for example. Took me hours to debug this. 



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

Mime
View raw message