airflow-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Felix Uellendall (JIRA)" <j...@apache.org>
Subject [jira] [Comment Edited] (AIRFLOW-2135) Errors running setup.py
Date Wed, 21 Feb 2018 21:27:00 GMT

    [ https://issues.apache.org/jira/browse/AIRFLOW-2135?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16372032#comment-16372032
] 

Felix Uellendall edited comment on AIRFLOW-2135 at 2/21/18 9:26 PM:
--------------------------------------------------------------------

Ok. I figured it out. Airflow base on a python version > 3.4.x is not working, because
of [setproctitle|https://github.com/dvarrazzo/py-setproctitle/issues/48].

So there is a reason why you put
{noformat}
Please install python(2.7.x or 3.4.x){noformat}
into the [docs|[https://github.com/apache/incubator-airflow/blob/master/CONTRIBUTING.md#development-and-testing]].

 


was (Author: feluelle):
Ok. I figured it out. Airflow base on a python version > 3.4.x is not working, because
of [setproctitle|https://github.com/dvarrazzo/py-setproctitle/issues/48].

So there is a reason why you put
{noformat}
Please install python(2.7.x or 3.4.x){noformat}
into the [docs|[https://github.com/apache/incubator-airflow/blob/master/CONTRIBUTING.md#development-and-testing]].

 

> Errors running setup.py
> -----------------------
>
>                 Key: AIRFLOW-2135
>                 URL: https://issues.apache.org/jira/browse/AIRFLOW-2135
>             Project: Apache Airflow
>          Issue Type: Bug
>            Reporter: Felix Uellendall
>            Priority: Major
>         Attachments: psutil_error.png, setproctitle_error.png
>
>
> Hey guys,
>  
> i am having trouble setting up the dev enviroment explained [here|https://github.com/apache/incubator-airflow/blob/master/CONTRIBUTING.md#development-and-testing]
> I ran the command
> {code:java}
> python setup.py install
> {code}
> and it throws me errors when it tries to install
> {noformat}
> 'setproctitle>=1.1.8, <2'{noformat}
> and
> {noformat}
> 'psutil>=4.2.0, <5.0.0'{noformat}
> I attached both errors.
> I am using fully updated Windows 10 with Python Version 3.6.4. When I ran the setup without
these packages it runs through. There are no more errors than these two.
>  
> It would be really great if you could help me with this because I want to contribute
to the project. :)
>  



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

Mime
View raw message