airflow-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "David De La Harpe Golden (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (AIRFLOW-1390) Airflow requiring alembic <0.9
Date Wed, 01 Nov 2017 21:58:00 GMT

     [ https://issues.apache.org/jira/browse/AIRFLOW-1390?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

David De La Harpe Golden updated AIRFLOW-1390:
----------------------------------------------
    Affects Version/s: 1.9.0

> Airflow requiring alembic <0.9
> ------------------------------
>
>                 Key: AIRFLOW-1390
>                 URL: https://issues.apache.org/jira/browse/AIRFLOW-1390
>             Project: Apache Airflow
>          Issue Type: Bug
>    Affects Versions: 1.9.0
>            Reporter: David De La Harpe Golden
>            Priority: Minor
>
> Airflow setup.py currently appears to require alembic <0.9 (as at [1.9.0alpha1|https://github.com/apache/incubator-airflow/blob/1.9.0alpha1/setup.py#L211]
)  However, alembic release is  up to 0.9.3.  Not sure whether this is an oversight or deliberate,
but it is potentially inconvenient if you need newer alembic features in the same env as airflow.
(In my case, alembic #412 / postgresql exclusion constraint support)



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

Mime
View raw message