airflow-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Nick McNutt (JIRA)" <j...@apache.org>
Subject [jira] [Created] (AIRFLOW-1749) AirflowConfigParser fails to override has_option from ConfigParser, causing broken LDAP config
Date Mon, 23 Oct 2017 15:43:00 GMT
Nick McNutt created AIRFLOW-1749:
------------------------------------

             Summary: AirflowConfigParser fails to override has_option from ConfigParser,
causing broken LDAP config
                 Key: AIRFLOW-1749
                 URL: https://issues.apache.org/jira/browse/AIRFLOW-1749
             Project: Apache Airflow
          Issue Type: Bug
          Components: configuration
    Affects Versions: Airflow 2.0, Airflow 1.8
         Environment: Ubuntu 16.04
            Reporter: Nick McNutt
            Priority: Minor


In configuration.py, class {{AirflowConfigParser}} fails to override {{has_option}} from {{ConfigParser}}.
 This breaks the following in ldap_auth.py:

{{if configuration.has_option("ldap", "search_scope"):
            search_scope = SUBTREE if configuration.get("ldap", "search_scope") == "SUBTREE"
else LEVEL}}

This code fails to consider whether any environment variable (e.g., {{AIRFLOW__LDAP__SEARCH_SCOPE}})
or command override's are set, meaning that LDAP configuration cannot be entirely set up through
environment variables.



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

Mime
View raw message