airflow-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Arthur Wiedmer (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (AIRFLOW-1165) airflow webservice crashes on ubuntu16 - python3
Date Mon, 10 Jul 2017 17:28:00 GMT

    [ https://issues.apache.org/jira/browse/AIRFLOW-1165?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16080698#comment-16080698
] 

Arthur Wiedmer commented on AIRFLOW-1165:
-----------------------------------------

A short fix until the version is upgraded can be the following

At the prompt
# Generating an RSA public/private-key pair
openssl genrsa -out private.pem 2048
# Generating a self-signed certificate
openssl req -new -x509 -key private.pem -out cacert.pem -days 1095

# In your airflow.cfg under [webserver]
web_server_ssl_cert = path/to/cacert.pem
web_server_ssl_key = path/to/private.pem

> airflow webservice crashes on ubuntu16 - python3 
> -------------------------------------------------
>
>                 Key: AIRFLOW-1165
>                 URL: https://issues.apache.org/jira/browse/AIRFLOW-1165
>             Project: Apache Airflow
>          Issue Type: Bug
>            Reporter: Hamed
>            Assignee: Arthur Wiedmer
>             Fix For: 1.9.0
>
>
> I am trying to run airflow webserver on ubuntu16, python3 and ran to this issue. Any
idea?
> {code}
> [2017-05-02 16:36:34,789] [24096] {_internal.py:87} WARNING -  * Debugger is active!
> [2017-05-02 16:36:34,790] [24096] {_internal.py:87} INFO -  * Debugger PIN: 294-518-137
> Exception in thread Thread-1:
> Traceback (most recent call last):
>   File "/usr/lib/python3.5/threading.py", line 914, in _bootstrap_inner
>     self.run()
>   File "/usr/lib/python3.5/threading.py", line 862, in run
>     self._target(*self._args, **self._kwargs)
>   File "/usr/local/lib/python3.5/dist-packages/werkzeug/serving.py", line 696, in inner
>     fd=fd)
>   File "/usr/local/lib/python3.5/dist-packages/werkzeug/serving.py", line 590, in make_server
>     passthrough_errors, ssl_context, fd=fd)
>   File "/usr/local/lib/python3.5/dist-packages/werkzeug/serving.py", line 525, in __init__
>     self.socket = ssl_context.wrap_socket(sock, server_side=True)
>   File "/usr/local/lib/python3.5/dist-packages/werkzeug/serving.py", line 447, in wrap_socket
>     ssl_version=self._protocol, **kwargs)
>   File "/usr/lib/python3.5/ssl.py", line 1069, in wrap_socket
>     ciphers=ciphers)
>   File "/usr/lib/python3.5/ssl.py", line 680, in __init__
>     raise ValueError("certfile must be specified for server-side "
> ValueError: certfile must be specified for server-side operations
> {code}



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

Mime
View raw message