airflow-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Bolke de Bruin (JIRA)" <j...@apache.org>
Subject [jira] [Resolved] (AIRFLOW-1231) Use flask_wtf.CSRFProtect instead of flask_wtf.CsrfProtect to remove deprecation warning
Date Sun, 21 May 2017 18:26:04 GMT

     [ https://issues.apache.org/jira/browse/AIRFLOW-1231?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Bolke de Bruin resolved AIRFLOW-1231.
-------------------------------------
       Resolution: Fixed
    Fix Version/s:     (was: Airflow 1.8)
                   1.9.0

Issue resolved by pull request #2313
[https://github.com/apache/incubator-airflow/pull/2313]

> Use flask_wtf.CSRFProtect instead of flask_wtf.CsrfProtect to remove deprecation warning
> ----------------------------------------------------------------------------------------
>
>                 Key: AIRFLOW-1231
>                 URL: https://issues.apache.org/jira/browse/AIRFLOW-1231
>             Project: Apache Airflow
>          Issue Type: Improvement
>          Components: core
>    Affects Versions: Airflow 1.8
>            Reporter: Stanislav Kudriashev
>            Assignee: Stanislav Kudriashev
>            Priority: Minor
>             Fix For: 1.9.0
>
>
> Use flask_wtf.CSRFProtect instead of flask_wtf.CsrfProtect.
> {code}
> ...app.py:23: FlaskWTFDeprecationWarning: "flask_wtf.CsrfProtect" has been renamed to
"CSRFProtect" and will be removed in 1.0.
>   csrf = CsrfProtect()
> {code}



--
This message was sent by Atlassian JIRA
(v6.3.15#6346)

Mime
View raw message