airflow-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Bolke de Bruin (JIRA)" <j...@apache.org>
Subject [jira] [Resolved] (AIRFLOW-935) Impossible to use plugin executors
Date Sat, 13 May 2017 10:59:04 GMT

     [ https://issues.apache.org/jira/browse/AIRFLOW-935?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Bolke de Bruin resolved AIRFLOW-935.
------------------------------------
       Resolution: Fixed
    Fix Version/s: 1.8.2

> Impossible to use plugin executors
> ----------------------------------
>
>                 Key: AIRFLOW-935
>                 URL: https://issues.apache.org/jira/browse/AIRFLOW-935
>             Project: Apache Airflow
>          Issue Type: Bug
>          Components: executor, plugins
>    Affects Versions: Airflow 1.8, 1.9.0
>            Reporter: Stijn Verhaegen
>             Fix For: 1.8.2
>
>
> revision eb5982d (included in 1.8) breaks plugin executors altogether. It makes a new
module for every plugin, so import statements need to be adapted, but the executor selection
is left unchanged, so it ends up assigning the plugin module as an executor.
> To reproduce: take any plugin which defines a custom executor and try to get it loaded
by setting `executor` in the airflow.cfg



--
This message was sent by Atlassian JIRA
(v6.3.15#6346)

Mime
View raw message