airflow-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jeremiah Lowin (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (AIRFLOW-821) Scheduler dagbag importing not Py3 compatible
Date Sun, 19 Feb 2017 13:32:44 GMT

     [ https://issues.apache.org/jira/browse/AIRFLOW-821?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Jeremiah Lowin updated AIRFLOW-821:
-----------------------------------
    Fix Version/s:     (was: 1.8.1)
                   1.9.0

> Scheduler dagbag importing not Py3 compatible
> ---------------------------------------------
>
>                 Key: AIRFLOW-821
>                 URL: https://issues.apache.org/jira/browse/AIRFLOW-821
>             Project: Apache Airflow
>          Issue Type: Bug
>          Components: scheduler
>    Affects Versions: 1.8.0b5
>         Environment: Python 3.4.4
>            Reporter: Szymon Matejczyk
>            Priority: Blocker
>             Fix For: 1.9.0
>
>
> Function {{update_import_errors}} in scheduler (https://github.com/apache/incubator-airflow/blob/master/airflow/jobs.py#L694)
in not Py3 compatible (using {{iteritems}} instead of {{items}}).



--
This message was sent by Atlassian JIRA
(v6.3.15#6346)

Mime
View raw message