airflow-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Mohamed Zenadi (JIRA)" <j...@apache.org>
Subject [jira] [Created] (AIRFLOW-804) Airflow installs latest Celery which does not support `sqla` transport
Date Wed, 25 Jan 2017 16:22:26 GMT
Mohamed Zenadi created AIRFLOW-804:
--------------------------------------

             Summary: Airflow installs latest Celery which does not support `sqla` transport
                 Key: AIRFLOW-804
                 URL: https://issues.apache.org/jira/browse/AIRFLOW-804
             Project: Apache Airflow
          Issue Type: Bug
            Reporter: Mohamed Zenadi
            Priority: Minor


Kombu dropped support for `sqla` transport in its version 4.x. With the default configuration
this will raise an exception:
```
$ airflow flower
[2017-01-25 17:20:05,064] {__init__.py:57} INFO - Using executor SequentialExecutor
[I 170125 17:20:07 command:136] Visit me at http://0.0.0.0:5555
Unknown Celery version
Traceback (most recent call last):
  File "/home/10025051/.linuxbrew/opt/python3/lib/python3.6/site-packages/kombu/transport/__init__.py",
line 53, in resolve_transport
    transport = TRANSPORT_ALIASES[transport]
KeyError: 'sqla'
```

A fix would be to change the default configuration for not using `sqla`. To avoid any confusing
error for a new user.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message