airflow-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "ASF subversion and git services (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (AIRFLOW-785) ImportError if cgroupspy is not installed
Date Sun, 22 Jan 2017 16:39:26 GMT

    [ https://issues.apache.org/jira/browse/AIRFLOW-785?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15833593#comment-15833593
] 

ASF subversion and git services commented on AIRFLOW-785:
---------------------------------------------------------

Commit 1a801cc3b4e5263278a780df59f30f72c21597dc in incubator-airflow's branch refs/heads/v1-8-test
from [~gsakkis]
[ https://git-wip-us.apache.org/repos/asf?p=incubator-airflow.git;h=1a801cc ]

[AIRFLOW-785] Don't import CgroupTaskRunner at global scope

cgroups is not a required dependency


> ImportError if cgroupspy is not installed
> -----------------------------------------
>
>                 Key: AIRFLOW-785
>                 URL: https://issues.apache.org/jira/browse/AIRFLOW-785
>             Project: Apache Airflow
>          Issue Type: Bug
>            Reporter: George Sakkis
>             Fix For: 1.8.1
>
>
> {{cgroups}} is not a required dependency but it is imported unconditonally, leading to
ImportError if it's not installed.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message