airflow-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "ASF subversion and git services (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (AIRFLOW-784) Cannot install with funcsigs > 1.0.0
Date Sun, 22 Jan 2017 16:36:27 GMT

    [ https://issues.apache.org/jira/browse/AIRFLOW-784?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15833583#comment-15833583
] 

ASF subversion and git services commented on AIRFLOW-784:
---------------------------------------------------------

Commit cce6ffcf079e1385de3611329f2817ba6f34fa66 in incubator-airflow's branch refs/heads/master
from [~gsakkis]
[ https://git-wip-us.apache.org/repos/asf?p=incubator-airflow.git;h=cce6ffc ]

[AIRFLOW-784] Pin funcsigs to 1.0.0


> Cannot install with funcsigs > 1.0.0
> ------------------------------------
>
>                 Key: AIRFLOW-784
>                 URL: https://issues.apache.org/jira/browse/AIRFLOW-784
>             Project: Apache Airflow
>          Issue Type: Bug
>            Reporter: George Sakkis
>
> Installing {{funcsigs > 1.0.0}} breaks Airflow installation due to [this commit|https://github.com/testing-cabal/funcsigs/commit/a2602c812c5011b4b97ab02402a93e725e571a9b]:
> bq. This still gives a poor user experience when an older setuptools is installed, but
at least folk reading setup.py will see the version they need.
> This is on a virtualenv on Ubuntu LTS 14.04:
> {noformat}
> $ virtualenv --version
> 1.11.4
> $ python -c "import setuptools as s; print s.__version__"
> 2.2
> {noformat}



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message