airflow-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jon McKenzie (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (AIRFLOW-332) Documentation says Sub-DAG names follow a convention, but in reality it's enforced
Date Wed, 13 Jul 2016 19:50:20 GMT

    [ https://issues.apache.org/jira/browse/AIRFLOW-332?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15375622#comment-15375622
] 

Jon McKenzie commented on AIRFLOW-332:
--------------------------------------

The naming convention also seems to be forced in the web UI. If I try to work around the name
validation, the "Zoom into Sub-DAG" button will fail because the JavaScript for that modal
hardcodes the naming convention, leading to a 404 if you try to click it.

> Documentation says Sub-DAG names follow a convention, but in reality it's enforced
> ----------------------------------------------------------------------------------
>
>                 Key: AIRFLOW-332
>                 URL: https://issues.apache.org/jira/browse/AIRFLOW-332
>             Project: Apache Airflow
>          Issue Type: Bug
>          Components: operators
>            Reporter: Jon McKenzie
>            Priority: Minor
>
> Currently, the documentation states that a Sub-DAG's name should follow the convention
{{<parent_dag_id>.<sub_dag_id>}}. In reality, this is not just a convention, but
it is enforced, and a {{SubDagOperator}} will fail to load if its name is incorrect. The documentation
should be updated to be a little clearer in this regard.
> Ideally, it would also be nice to either specify via an option that this validation should
take place (or not), or be easier to subclass {{SubDagOperator}} and override the validation,
so that users can have their own naming conventions.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message