airflow-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Greg Reda (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (AIRFLOW-43) Tasks never run in externally triggered DAGRun
Date Fri, 10 Jun 2016 19:02:21 GMT

    [ https://issues.apache.org/jira/browse/AIRFLOW-43?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15325087#comment-15325087
] 

Greg Reda commented on AIRFLOW-43:
----------------------------------

Just ran into this same issue and it stemmed from not having the Dag set to "on" in the webapp.

I could have missed something in the docs, but it didn't seem clear that to trigger a one-off
dag you need to:
1. Have the scheduler running.
2. `airflow trigger_dag dag_id`
3. Turn the dag on in the webapp.

Is there anything in the docs that I might have missed that makes this clear? I was quite
confused.

> Tasks never run in externally triggered DAGRun
> ----------------------------------------------
>
>                 Key: AIRFLOW-43
>                 URL: https://issues.apache.org/jira/browse/AIRFLOW-43
>             Project: Apache Airflow
>          Issue Type: Bug
>    Affects Versions: Airflow 1.7.0
>         Environment: OSX, Python 2.7.5
>            Reporter: Chris Johnson
>            Assignee: Siddharth Anand
>            Priority: Critical
>
> I have a DAG which should only be run as needed (no schedule interval):
> dag = DAG(
>     dag_id='major_integ_cycle',
>     default_args=args,
>     schedule_interval=None,
> )
> I attempted to start this using `airflow trigger_dag NAME` but the tasks never run. 
The scheduler has noted the fact that itthe DAG was triggered: INFO - Created <DagRun major_integ_cycle
@ 2016-05-03 08:36:16.032474: manual__2016-05-03T08:36:16.032474, externally triggered: True>
> The tasks are currently very vanilla test cases, all look like this:
> task_mdc = op.BashOperator(
>     task_id='master_data_cycle',
>     bash_command='sleep 1',
>     dag=dag,
> )
> Have I misunderstood?  Or is not running a bug in this case?



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message