airavata-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Abhishek Jain <ajai...@binghamton.edu>
Subject Re: Failed Sending Account Confirmation Email after Account Creation with local PGA - WSO2 IS set up
Date Thu, 02 Jun 2016 14:57:37 GMT
Hi Bikramjeet,
Can you elaborate on the problem you are facing ? Can you send your wso2 IS
error log ?

On Thu, Jun 2, 2016 at 7:59 AM, Bikramjeet Singh <
singh.bikramjeet3@gmail.com> wrote:

> Hi Abhishek,
> I encountered the same error while sending email while account creation,
> although I had earlier set up wso2 and changed OAuth client and OAuth
> secret too, how were you able to solve it finally?
>
> Thanks
>
> On Sat, May 28, 2016 at 8:35 AM, Abhishek Jain <ajain13@binghamton.edu>
> wrote:
>
>> Hi Jeff,
>> I directed the address to my public folder in my PGA installation.
>> So the link now looks like :
>>
>>
>> http://localhost/airavata-php-gateway/public/confirm-user-registration?confirmation=87348d48-c6c7-44a3-87d2-39ed3bb7e439&userstoredomain=PRIMARY&username=jainabhishek99&tenantdomain=test.bu.com
>>
>> I had to replace https with http which made it go through. But now, when
>> I visit the link, I am getting the following message :
>>
>> "Looks like something went wrong. Please go back and try again or report
>> the problem using help feature."
>>
>> I have attached the screenshot below.
>>
>>
>> On Fri, May 27, 2016 at 10:29 PM, Jeffery Kinnison <
>> Jeffery.D.Kinnison.1@nd.edu> wrote:
>>
>>> No problem, happy to help!
>>>
>>> On Fri, May 27, 2016 at 10:12 PM, Pierce, Marlon <marpierc@iu.edu>
>>> wrote:
>>>
>>>> +1, thanks, Jeff!
>>>>
>>>>
>>>>
>>>> *From: *Abhishek Jain <ajain13@binghamton.edu>
>>>> *Reply-To: *"dev@airavata.apache.org" <dev@airavata.apache.org>
>>>> *Date: *Friday, May 27, 2016 at 8:35 PM
>>>> *To: *dev <dev@airavata.apache.org>
>>>> *Subject: *Re: Failed Sending Account Confirmation Email after Account
>>>> Creation with local PGA - WSO2 IS set up
>>>>
>>>>
>>>>
>>>> Yes. I think I verified it with my set-up and then added them which
>>>> turned out to be similar. I will double check it.
>>>>
>>>> Thanks a lot for the help !
>>>>
>>>>
>>>>
>>>> On Fri, May 27, 2016 at 8:31 PM, Jeffery Kinnison <
>>>> Jeffery.D.Kinnison.1@nd.edu> wrote:
>>>>
>>>> So those addresses need to be directed to your public folder in your
>>>> PGA install--the actual address will depend on how you have set up Apache
>>>> server, I just sent them as an example.
>>>>
>>>>
>>>>
>>>> On Fri, May 27, 2016 at 7:32 PM, Abhishek Jain <ajain13@binghamton.edu>
>>>> wrote:
>>>>
>>>> Yes. Google was blocking the sign-in attempt. I allowed less secure
>>>> apps to sign-in. I finally could receive a confirmation link which is as
>>>> follows :
>>>>
>>>>
>>>>
>>>>
>>>> https://localhost/airavata-php-gateway/public/confirm-user-registration?confirmation=a507f404-858f-44f2-81d4-c8b2a9a7be3f&userstoredomain=PRIMARY&username=jainabhishek96&tenantdomain=test.bu.com
>>>>
>>>> But, when I visit the link , I get an error stating that the site can't
>>>> be reached. I believe the link is not correct.
>>>>
>>>>
>>>>
>>>> On Fri, May 27, 2016 at 7:12 PM, Jeff <jkinniso@nd.edu> wrote:
>>>>
>>>> Has abhi.airavata94@gmail.com received any emails from Google about a
>>>> blocked sign in attempt? If so, try following the instructions at
>>>> https://support.google.com/accounts/answer/6010255?hl=en
>>>>
>>>>
>>>>
>>>> On 05/27/2016 07:01 PM, Abhishek Jain wrote:
>>>>
>>>> This is how my identiy-mgt.properties file looks like :
>>>>
>>>>
>>>>
>>>> *# Enable authentication to the service using super tenant credentials
>>>> and invoke operations on tenants.*
>>>>
>>>>
>>>>
>>>> *UserInfoRecovery.SaaSEnable=false*
>>>>
>>>>
>>>>
>>>> *# Enable email sending function when recovering the account and
>>>> verifying the user creation*
>>>>
>>>>
>>>>
>>>> *Notification.Sending.Enable=true*
>>>>
>>>> *Notification.Expire.Time=7200*
>>>>
>>>>
>>>>
>>>> *# Enable internal email sending module. If "false", email sending data
>>>> would be available to application via webservice. Then application can send
>>>> the email using its own email sender *
>>>>
>>>>
>>>>
>>>> *Notification.Sending.Internally.Managed=true*
>>>>
>>>>
>>>>
>>>> *# Enable verification of account creation. When self registration is
>>>> done,  user would be verified by sending email (confirmation link) to
>>>> user's email account*
>>>>
>>>>
>>>>
>>>> *UserAccount.Verification.Enable=false*
>>>>
>>>>
>>>>
>>>> *UserAccount.Recovery.Enable=false*
>>>>
>>>>
>>>>
>>>>
>>>>
>>>> *# Whether user can do the verification or not. If value is defined for
>>>> role, Then the email is sent to users that have been assigned to this role.
>>>> Not for the user who is registered.*
>>>>
>>>>
>>>>
>>>> *UserAccount.Verification.Role=*
>>>>
>>>>
>>>>
>>>> *# Whether captcha verification is done by identity server or
>>>> application level*
>>>>
>>>>
>>>>
>>>> *Captcha.Verification.Internally.Managed=false*
>>>>
>>>>
>>>>
>>>> *# Whether temporary passwords are used when creating users or
>>>> recovering accounts.*
>>>>
>>>>
>>>>
>>>> *Temporary.Password.Enable=false*
>>>>
>>>> *Temporary.Password.OneTime=false*
>>>>
>>>> *Temporary.Password.Expire.Time=0*
>>>>
>>>>
>>>>
>>>> *# Enable authentication rules other than password check *
>>>>
>>>>
>>>>
>>>> *Authentication.Policy.Enable=true*
>>>>
>>>>
>>>>
>>>> *# Enable following checks during authentication.  By default account
>>>> lock check is enabled.*
>>>>
>>>>
>>>>
>>>> *Authentication.Policy.Check.Account.Exist=false *
>>>>
>>>> *Authentication.Policy.Check.Account.Lock=false*
>>>>
>>>> *Authentication.Policy.Check.OneTime.Password=false*
>>>>
>>>> *Authentication.Policy.Check.Password.Expire=false*
>>>>
>>>>
>>>>
>>>> *# Configuration to build an authentication policy*
>>>>
>>>>
>>>>
>>>> *Authentication.Policy.Password.Expire.Time=0*
>>>>
>>>> *# If account verification is not enabled, following property will
>>>> decide where user must be lock or not after user is created *
>>>>
>>>> *Authentication.Policy.Account.Lock.On.Creation=true*
>>>>
>>>> *Authentication.Policy.Account.Lock.Time=0*
>>>>
>>>> *Authentication.Policy.Account.Lock.On.Failure=false*
>>>>
>>>> *Authentication.Policy.Account.Lock.On.Failure.Max.Attempts=0*
>>>>
>>>>
>>>>
>>>> *# Define pluggable extension points*
>>>>
>>>>
>>>>
>>>>
>>>> *Identity.Mgt.Random.Password.Grenerator=org.wso2.carbon.identity.mgt.password.DefaultPasswordGenerator*
>>>>
>>>>
>>>> *#Identity.Mgt.User.Data.Store=org.wso2.carbon.identity.mgt.store.UserStoreBasedIdentityDataStore*
>>>>
>>>>
>>>> *Identity.Mgt.User.Data.Store=org.wso2.carbon.identity.mgt.store.JDBCIdentityDataStore*
>>>>
>>>>
>>>> *Identity.Mgt.Notification.Sending.Module.1=org.wso2.carbon.identity.mgt.mail.DefaultEmailSendingModule*
>>>>
>>>>
>>>> *Identity.Mgt.User.Recovery.Data.Store=org.wso2.carbon.identity.mgt.store.RegistryRecoveryDataStore*
>>>>
>>>> *Identity.Mgt.Registry.CleanUpPeriod=1440*
>>>>
>>>>
>>>>
>>>>
>>>>
>>>> *# Define password policy enforce extensions*
>>>>
>>>>
>>>>
>>>>
>>>> *#Password.policy.extensions.1=org.wso2.carbon.identity.mgt.policy.password.DefaultPasswordLengthPolicy*
>>>>
>>>> *#Password.policy.extensions.1.min.length=6*
>>>>
>>>> *#Password.policy.extensions.1.max.length=12*
>>>>
>>>>
>>>> *#Password.policy.extensions.2=org.wso2.carbon.identity.mgt.policy.password.DefaultPasswordNamePolicy*
>>>>
>>>>
>>>> *#Password.policy.extensions.3=org.wso2.carbon.identity.mgt.policy.password.DefaultPasswordPatternPolicy*
>>>>
>>>>
>>>> *#Password.policy.extensions.3.pattern=^((?=.*\\d)(?=.*[a-z])(?=.*[A-Z])(?=.*[!@#$%&*])).{0,100}$*
>>>>
>>>> *#Password.policy.extensions.3.errorMsg='Password pattern policy
>>>> violated. Password should contain a digit[0-9], a lower case letter[a-z],
>>>> an upper case letter[A-Z], one of !@#$%&* characters'*
>>>>
>>>>
>>>>
>>>> On Fri, May 27, 2016 at 6:45 PM, Abhishek Jain <ajain13@binghamton.edu>
>>>> wrote:
>>>>
>>>> Hi Jeff,
>>>>
>>>> Yes. I configured MailTransportSender. I configured it as follows :
>>>>
>>>>
>>>>
>>>>  <transportSender name="mailto"
>>>>
>>>>
>>>>  class="org.apache.axis2.transport.mail.MailTransportSender">
>>>>
>>>>         <parameter name="mail.smtp.from">abhi.airavata94@gmail.com
>>>> </parameter>
>>>>
>>>>         <parameter name="mail.smtp.user">abhi.airavata94</parameter>
>>>>
>>>>         <parameter name="mail.smtp.password">somepassword</parameter>
>>>>
>>>>         <parameter name="mail.smtp.host">smtp.gmail.com</parameter>
>>>>
>>>>
>>>>
>>>>         <parameter name="mail.smtp.port">587</parameter>
>>>>
>>>>         <parameter name="mail.smtp.starttls.enable">true</parameter>
>>>>
>>>>         <parameter name="mail.smtp.auth">true</parameter>
>>>>
>>>>     </transportSender>
>>>>
>>>>
>>>>
>>>> It stills throws the same error.
>>>>
>>>>
>>>>
>>>>
>>>>
>>>>
>>>>
>>>>
>>>>
>>>>
>>>>
>>>> On Fri, May 27, 2016 at 6:34 PM, Abhishek Jain <ajain13@binghamton.edu>
>>>> wrote:
>>>>
>>>> Yes I have configured that. I will verify it once again and then come
>>>> back to you.
>>>>
>>>>
>>>>
>>>> On Fri, May 27, 2016 at 6:31 PM, Jeff <jkinniso@nd.edu> wrote:
>>>>
>>>> Hi Abishek,
>>>>
>>>> Did you configure everything like in
>>>> http://airavata.readthedocs.io/en/latest/Own-WSO2-IS-Configuration/ ?
>>>> There is a part near the bottom of the page (right above step 4) about
>>>> configuring the MailTransportSender, which is the part of code throwing the
>>>> error.
>>>>
>>>> Jeff K.
>>>>
>>>>
>>>>
>>>> On 05/27/2016 06:14 PM, Abhishek Jain wrote:
>>>>
>>>> Hi Jeff,
>>>>
>>>> I had forgotten to configure OAuth for the service provider.
>>>>
>>>> I followed the instructions mentioned in the link you just shared and
>>>> configured , and added the client key and  secret key in the pga_config.php.
>>>>
>>>> Also, I changed the links in the email-admin config.xml as you had
>>>> mentioned.
>>>>
>>>> But it looks like the issue did not resolve. It still fails to send an
>>>> email.
>>>>
>>>> These are how my files look now.
>>>>
>>>>
>>>>
>>>> On Fri, May 27, 2016 at 5:56 PM, Jeff <jkinniso@nd.edu> wrote:
>>>>
>>>> It looks like your OAuth client key and OAuth client secret in
>>>> pga_config.php are the defaults--have you configured OAuth for your service
>>>> provider? This page of the docs has the relevant setup
>>>> http://airavata.readthedocs.io/en/latest/WSO2-IS-Configuration/
>>>>
>>>> Once you have the OAuth service set up, copy the client key and secret
>>>> key that are created into your pga-config.php.
>>>>
>>>> The other thing is that the links in email-admin-config.xml should be
>>>> set to something like
>>>>
>>>>
>>>> https://localhost/airavata-php-gateway/public/reset-password?confirmation=
>>>> {confirmation-code}&amp;userstoredomain={userstore-domain}&amp;username={url:user-name}&amp;tenantdomain={tenant-domain}
>>>>
>>>> for Password Reset and
>>>>
>>>>
>>>> https://localhost/airavata-php-gateway/public/confirm-user-registration?confirmation=
>>>> {confirmation-code}&amp;userstoredomain={userstore-domain}&amp;username={url:user-name}&amp;tenantdomain={tenant-domain}
>>>>
>>>> for Account Confirmation. This points them to the local PGA pages that
>>>> handle password reset and account confirmation, respectively.
>>>>
>>>> Hope this helps!
>>>> Jeff K.
>>>>
>>>>
>>>>
>>>> On Fri, May 27, 2016 at 5:42 PM, Abhishek Jain <ajain13@binghamton.edu>
>>>> wrote:
>>>>
>>>>
>>>> Hi All,
>>>>
>>>>
>>>>
>>>> I have locally set up the PGA and WSO2. They are up and running. I
>>>> added the admin user credentials of the tenant that I created in the
>>>> pga_conf.php file. So now when I try creating an account, I get a message
>>>> that a confirmation link has been sent to the email account, but I can see
>>>> an error in my IS log saying that sending of email has failed which is as
>>>> follows :
>>>>
>>>>
>>>>
>>>> *[2016-05-27 14:19:34,698] @test.bu.com <http://test.bu.com> [1] [IS]
>>>> INFO {org.wso2.carbon.identity.mgt.mail.DefaultEmailSendingModule} -
>>>>  Sending user credentials configuration mail to jainabhishek93@gmail.com
>>>> <jainabhishek93@gmail.com>*
>>>>
>>>> *[2016-05-27 14:19:35,403] @test.bu.com <http://test.bu.com> [1]
>>>> [IS]ERROR {org.wso2.carbon.identity.mgt.mail.DefaultEmailSendingModule} -
>>>>  Failed Sending Email*
>>>>
>>>> *org.apache.axis2.AxisFault: Error generating mail message*
>>>>
>>>> *at
>>>> org.apache.axis2.transport.base.AbstractTransportSender.handleException(AbstractTransportSender.java:226)*
>>>>
>>>> *at
>>>> org.apache.axis2.transport.mail.MailTransportSender.sendMessage(MailTransportSender.java:184)*
>>>>
>>>> *at
>>>> org.apache.axis2.transport.base.AbstractTransportSender.invoke(AbstractTransportSender.java:112)*
>>>>
>>>> *at org.apache.axis2.engine.AxisEngine.send(AxisEngine.java:442)*
>>>>
>>>> *at
>>>> org.apache.axis2.description.OutOnlyAxisOperationClient.executeImpl(OutOnlyAxisOperation.java:297)*
>>>>
>>>> *at
>>>> org.apache.axis2.client.OperationClient.execute(OperationClient.java:149)*
>>>>
>>>> *at
>>>> org.apache.axis2.client.ServiceClient.fireAndForget(ServiceClient.java:511)*
>>>>
>>>> *at
>>>> org.apache.axis2.client.ServiceClient.fireAndForget(ServiceClient.java:488)*
>>>>
>>>> *at
>>>> org.wso2.carbon.identity.mgt.mail.DefaultEmailSendingModule.sendEmail(DefaultEmailSendingModule.java:116)*
>>>>
>>>> *at
>>>> org.wso2.carbon.identity.mgt.mail.AbstractEmailSendingModule.notifyUser(AbstractEmailSendingModule.java:59)*
>>>>
>>>> *at
>>>> org.wso2.carbon.identity.mgt.NotificationSendingModule.run(NotificationSendingModule.java:33)*
>>>>
>>>> *at
>>>> java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:471)*
>>>>
>>>> *at java.util.concurrent.FutureTask.run(FutureTask.java:262)*
>>>>
>>>> *at
>>>> java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145)*
>>>>
>>>> *at
>>>> java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615)*
>>>>
>>>> *at java.lang.Thread.run(Thread.java:745)*
>>>>
>>>> *Caused by: org.apache.axis2.AxisFault: Error creating mail message or
>>>> sending it to the configured server*
>>>>
>>>> *at
>>>> org.apache.axis2.transport.base.AbstractTransportSender.handleException(AbstractTransportSender.java:226)*
>>>>
>>>> *at
>>>> org.apache.axis2.transport.mail.MailTransportSender.sendMail(MailTransportSender.java:505)*
>>>>
>>>> *at
>>>> org.apache.axis2.transport.mail.MailTransportSender.sendMessage(MailTransportSender.java:175)*
>>>>
>>>> *... 14 more*
>>>>
>>>> *Caused by: javax.mail.AuthenticationFailedException*
>>>>
>>>> *at javax.mail.Service.connect(Service.java:306)*
>>>>
>>>> *at javax.mail.Service.connect(Service.java:156)*
>>>>
>>>> *at javax.mail.Service.connect(Service.java:105)*
>>>>
>>>> *at javax.mail.Transport.send0(Transport.java:168)*
>>>>
>>>> *at javax.mail.Transport.send(Transport.java:98)*
>>>>
>>>> *at
>>>> org.apache.axis2.transport.mail.MailTransportSender.sendMail(MailTransportSender.java:494)*
>>>>
>>>> *... 15 more*
>>>>
>>>>
>>>>
>>>>
>>>>
>>>> I am attaching my pga_conf.php file and also, the
>>>> email-admin-config.xml file.
>>>>
>>>>
>>>>
>>>> Also, I am attaching the screenshots of my tenant details and service
>>>> provider details.
>>>>
>>>>
>>>>
>>>> Can you tell me what am I missing out or if I have made a mistake in
>>>> the pga_config.php file ?
>>>>
>>>>
>>>>
>>>>
>>>>
>>>> --
>>>>
>>>> Thanks & Regards,
>>>>
>>>> Abhishek Jain
>>>>
>>>>
>>>>
>>>> *Graduate Student*
>>>>
>>>> *Department of Computer Science*
>>>>
>>>> *Thomas J. Watson School of Engineering & Applied Science*
>>>>
>>>> *Binghamton University - State Univeristy of New York (SUNY)*
>>>>
>>>>
>>>>
>>>>
>>>>
>>>>
>>>>
>>>>
>>>>
>>>>
>>>>
>>>> --
>>>>
>>>> Thanks & Regards,
>>>>
>>>> Abhishek Jain
>>>>
>>>>
>>>>
>>>> *Graduate Student*
>>>>
>>>> *Department of Computer Science*
>>>>
>>>> *Thomas J. Watson School of Engineering & Applied Science*
>>>>
>>>> *Binghamton University - State Univeristy of New York (SUNY)*
>>>>
>>>>
>>>>
>>>>
>>>>
>>>>
>>>>
>>>>
>>>>
>>>>
>>>>
>>>> --
>>>>
>>>> Thanks & Regards,
>>>>
>>>> Abhishek Jain
>>>>
>>>>
>>>>
>>>> *Graduate Student*
>>>>
>>>> *Department of Computer Science*
>>>>
>>>> *Thomas J. Watson School of Engineering & Applied Science*
>>>>
>>>> *Binghamton University - State Univeristy of New York (SUNY)*
>>>>
>>>>
>>>>
>>>>
>>>>
>>>>
>>>>
>>>>
>>>>
>>>> --
>>>>
>>>> Thanks & Regards,
>>>>
>>>> Abhishek Jain
>>>>
>>>>
>>>>
>>>> *Graduate Student*
>>>>
>>>> *Department of Computer Science*
>>>>
>>>> *Thomas J. Watson School of Engineering & Applied Science*
>>>>
>>>> *Binghamton University - State Univeristy of New York (SUNY)*
>>>>
>>>>
>>>>
>>>>
>>>>
>>>>
>>>>
>>>>
>>>>
>>>> --
>>>>
>>>> Thanks & Regards,
>>>>
>>>> Abhishek Jain
>>>>
>>>>
>>>>
>>>> *Graduate Student*
>>>>
>>>> *Department of Computer Science*
>>>>
>>>> *Thomas J. Watson School of Engineering & Applied Science*
>>>>
>>>> *Binghamton University - State Univeristy of New York (SUNY)*
>>>>
>>>>
>>>>
>>>>
>>>>
>>>>
>>>>
>>>>
>>>>
>>>>
>>>>
>>>> --
>>>>
>>>> Thanks & Regards,
>>>>
>>>> Abhishek Jain
>>>>
>>>>
>>>>
>>>> *Graduate Student*
>>>>
>>>> *Department of Computer Science*
>>>>
>>>> *Thomas J. Watson School of Engineering & Applied Science*
>>>>
>>>> *Binghamton University - State Univeristy of New York (SUNY)*
>>>>
>>>>
>>>>
>>>>
>>>>
>>>>
>>>>
>>>>
>>>>
>>>>
>>>>
>>>> --
>>>>
>>>> Thanks & Regards,
>>>>
>>>> Abhishek Jain
>>>>
>>>>
>>>>
>>>> *Graduate Student*
>>>>
>>>> *Department of Computer Science*
>>>>
>>>> *Thomas J. Watson School of Engineering & Applied Science*
>>>>
>>>> *Binghamton University - State Univeristy of New York (SUNY)*
>>>>
>>>>
>>>>
>>>>
>>>>
>>>
>>>
>>
>>
>> --
>> Thanks & Regards,
>> Abhishek Jain
>>
>> *Graduate Student*
>> *Department of Computer Science*
>> *Thomas J. Watson School of Engineering & Applied Science*
>> *Binghamton University - State Univeristy of New York (SUNY)*
>>
>>
>>
>


-- 
Thanks & Regards,
Abhishek Jain

*Graduate Student*
*Department of Computer Science*
*Thomas J. Watson School of Engineering & Applied Science*
*Binghamton University - State University of New York (SUNY)*

Mime
View raw message