airavata-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Abhishek Jain <ajai...@binghamton.edu>
Subject Re: Failed Sending Account Confirmation Email after Account Creation with local PGA - WSO2 IS set up
Date Wed, 01 Jun 2016 18:06:24 GMT
Try with just http.

On Wednesday, June 1, 2016, Bikramjeet Singh <singh.bikramjeet3@gmail.com>
wrote:

> Hi abhishek,
> This issue is resolved and apache server has started  but now I'm getting
> this message on localhost.
> PFA
>
> On Wed, Jun 1, 2016 at 8:50 PM, Bikramjeet Singh <
> singh.bikramjeet3@gmail.com
> <javascript:_e(%7B%7D,'cvml','singh.bikramjeet3@gmail.com');>> wrote:
>
>> This-
>> [linfestus@localhost html]$ apachectl start
>> Job for httpd.service failed because the control process exited with
>> error code. See "systemctl status httpd.service" and "journalctl -xe" for
>> details.
>> [linfestus@localhost html]$ systemctl status httpd.service
>> ‚óŹ httpd.service - The Apache HTTP Server
>>    Loaded: loaded (/usr/lib/systemd/system/httpd.service; enabled; vendor
>> preset: disabled)
>>    Active: failed (Result: exit-code) since Wed 2016-06-01 16:47:58 IST;
>> 20s ago
>>      Docs: man:httpd(8)
>>            man:apachectl(8)
>>   Process: 8837 ExecStop=/bin/kill -WINCH ${MAINPID} (code=exited,
>> status=1/FAILURE)
>>   Process: 8815 ExecStart=/usr/sbin/httpd $OPTIONS -DFOREGROUND
>> (code=exited, status=1/FAILURE)
>>  Main PID: 8815 (code=exited, status=1/FAILURE)
>>
>>
>> On Wed, Jun 1, 2016 at 7:27 PM, Abhishek Jain <ajain13@binghamton.edu
>> <javascript:_e(%7B%7D,'cvml','ajain13@binghamton.edu');>> wrote:
>>
>>> Can you tell me what error you are getting ?
>>>
>>>
>>> On Wednesday, June 1, 2016, Bikramjeet Singh <
>>> singh.bikramjeet3@gmail.com
>>> <javascript:_e(%7B%7D,'cvml','singh.bikramjeet3@gmail.com');>> wrote:
>>>
>>>> Hi abhishek,
>>>> Thanks I updated the file,getting an error while starting Apache now
>>>> which was not happening earlier so I'm first trying to find the solution
to
>>>> it.
>>>>
>>>> Thanks
>>>>
>>>> On Wednesday 1 June 2016, Abhishek Jain <ajain13@binghamton.edu> wrote:
>>>>
>>>>> Hi Bikramjeet,
>>>>>
>>>>> I think you forgot to reply to the dev list. Please make sure that you
>>>>> reply to the dev list as other devs who are facing the same issue can
refer
>>>>> it in future.
>>>>>
>>>>> My local PGA installation is on Ubuntu. I installed Cent OS and tried
>>>>> installing PGA locally on it to help you out.I could locally install
PGA
>>>>> locally on Cent OS too.
>>>>>
>>>>> So I had a look at your httpd.conf file. There are a couple of things
>>>>> you have to change in it.
>>>>>
>>>>> 1. You have to point to the public folder in airavata-php-gateway
>>>>> repository (assuming thats the name of your PGA repository).
>>>>>
>>>>> #
>>>>> # DocumentRoot: The directory out of which you will serve your
>>>>> # documents. By default, all requests are taken from this directory,
but
>>>>> # symbolic links and aliases may be used to point to other locations.
>>>>> #
>>>>> DocumentRoot "/var/www/html/airavata-php-gateway/public"
>>>>>
>>>>> #
>>>>>
>>>>> 2.
>>>>>
>>>>> # Further relax access to the default document root:
>>>>> <Directory "/var/www/html/airavata-php-gateway/public">
>>>>>    #
>>>>>
>>>>>
>>>>> Once you make these 2 changes,
>>>>>
>>>>> Run your apache server :
>>>>>
>>>>>     sudo apachectl start
>>>>>
>>>>> Enter "localhost" as the address in your browser and it should work.
>>>>>
>>>>> Otherwise provide "localhost:80" as the address.
>>>>>
>>>>> I am also attaching my httpd.conf file for your reference.
>>>>>
>>>>> Hope this helps.
>>>>>
>>>>>
>>>>> On Tue, May 31, 2016 at 10:37 PM, Bikramjeet Singh <
>>>>> singh.bikramjeet3@gmail.com> wrote:
>>>>>
>>>>>> Hi,
>>>>>> I'm using centos for pga and there is only httpd.conf file which
I'm
>>>>>> attaching and is there a need to create virtual hosts? if yes, then
with
>>>>>> which configurations?
>>>>>>
>>>>>>
>>>>>>
>>>>>> On Wed, Jun 1, 2016 at 5:07 AM, Abhishek Jain <ajain13@binghamton.edu
>>>>>> > wrote:
>>>>>>
>>>>>>> Hi Bikramjeet,
>>>>>>>
>>>>>>> Are you trying to install on your Macbook ? As httpd.conf is
not
>>>>>>> required for Ubuntu.
>>>>>>>
>>>>>>> Ubuntu doesn't use httpd.conf as standard, instead global
>>>>>>> configuration stuff for apache is found in /etc/apache2/apache2.conf.
>>>>>>>
>>>>>>> Can you also share your default vhost config file which is found
in
>>>>>>> the <apache2 Root>/sites-available/ ?
>>>>>>>
>>>>>>>
>>>>>>>
>>>>>>> On Tue, May 31, 2016 at 11:30 AM, Bikramjeet Singh <
>>>>>>> singh.bikramjeet3@gmail.com> wrote:
>>>>>>>
>>>>>>>> Hi,
>>>>>>>> I didn't check yet, but I tried
>>>>>>>> localhost/airavata-php-gateway/public also but the page was
not accessible,
>>>>>>>> I wondered there might be some else link and if this is the
link only can
>>>>>>>> you share your httpd.conf file?
>>>>>>>>
>>>>>>>> Thanks
>>>>>>>>
>>>>>>>>
>>>>>>>> On Tuesday 31 May 2016, Abhishek Jain <ajain13@binghamton.edu>
>>>>>>>> wrote:
>>>>>>>>
>>>>>>>>> Hi Bikramjeet,
>>>>>>>>> Did ur problem resolve ?
>>>>>>>>>
>>>>>>>>> On Tuesday, May 31, 2016, Abhishek Jain <ajain13@binghamton.edu>
>>>>>>>>> wrote:
>>>>>>>>>
>>>>>>>>>> Hi Bikramjeet,
>>>>>>>>>> Once you have locally set up the PGA, you should
be able to
>>>>>>>>>> access the PGA page on localhost. It depends how
you have configured you
>>>>>>>>>> Apache server.
>>>>>>>>>>
>>>>>>>>>> On Tuesday, May 31, 2016, Bikramjeet Singh <
>>>>>>>>>> singh.bikramjeet3@gmail.com> wrote:
>>>>>>>>>>
>>>>>>>>>>> Hi Abhishek,
>>>>>>>>>>>
>>>>>>>>>>> I've airavata running, and PGA and wso2 configured,
can you
>>>>>>>>>>> please tell me how to use PGA, I mean how to
access gateway admin page of
>>>>>>>>>>> PGA, I cant find link anywhere.
>>>>>>>>>>>
>>>>>>>>>>> Thanks
>>>>>>>>>>>
>>>>>>>>>>> On Sat, May 28, 2016 at 4:15 AM, Abhishek Jain
<
>>>>>>>>>>> ajain13@binghamton.edu> wrote:
>>>>>>>>>>>
>>>>>>>>>>>> Hi Jeff,
>>>>>>>>>>>> Yes. I configured MailTransportSender. I
configured it as
>>>>>>>>>>>> follows :
>>>>>>>>>>>>
>>>>>>>>>>>>  <transportSender name="mailto"
>>>>>>>>>>>>
>>>>>>>>>>>>  class="org.apache.axis2.transport.mail.MailTransportSender">
>>>>>>>>>>>>         <parameter name="mail.smtp.from">
>>>>>>>>>>>> abhi.airavata94@gmail.com</parameter>
>>>>>>>>>>>>         <parameter
>>>>>>>>>>>> name="mail.smtp.user">abhi.airavata94</parameter>
>>>>>>>>>>>>         <parameter
>>>>>>>>>>>> name="mail.smtp.password">somepassword</parameter>
>>>>>>>>>>>>         <parameter name="mail.smtp.host">smtp.gmail.com
>>>>>>>>>>>> </parameter>
>>>>>>>>>>>>
>>>>>>>>>>>>         <parameter name="mail.smtp.port">587</parameter>
>>>>>>>>>>>>         <parameter
>>>>>>>>>>>> name="mail.smtp.starttls.enable">true</parameter>
>>>>>>>>>>>>         <parameter name="mail.smtp.auth">true</parameter>
>>>>>>>>>>>>     </transportSender>
>>>>>>>>>>>>
>>>>>>>>>>>> It stills throws the same error.
>>>>>>>>>>>>
>>>>>>>>>>>>
>>>>>>>>>>>>
>>>>>>>>>>>>
>>>>>>>>>>>>
>>>>>>>>>>>> On Fri, May 27, 2016 at 6:34 PM, Abhishek
Jain <
>>>>>>>>>>>> ajain13@binghamton.edu> wrote:
>>>>>>>>>>>>
>>>>>>>>>>>>> Yes I have configured that. I will verify
it once again and
>>>>>>>>>>>>> then come back to you.
>>>>>>>>>>>>>
>>>>>>>>>>>>> On Fri, May 27, 2016 at 6:31 PM, Jeff
<jkinniso@nd.edu> wrote:
>>>>>>>>>>>>>
>>>>>>>>>>>>>> Hi Abishek,
>>>>>>>>>>>>>>
>>>>>>>>>>>>>> Did you configure everything like
in
>>>>>>>>>>>>>> http://airavata.readthedocs.io/en/latest/Own-WSO2-IS-Configuration/
>>>>>>>>>>>>>> ? There is a part near the bottom
of the page (right above step 4) about
>>>>>>>>>>>>>> configuring the MailTransportSender,
which is the part of code throwing the
>>>>>>>>>>>>>> error.
>>>>>>>>>>>>>>
>>>>>>>>>>>>>> Jeff K.
>>>>>>>>>>>>>>
>>>>>>>>>>>>>>
>>>>>>>>>>>>>> On 05/27/2016 06:14 PM, Abhishek
Jain wrote:
>>>>>>>>>>>>>>
>>>>>>>>>>>>>> Hi Jeff,
>>>>>>>>>>>>>> I had forgotten to configure OAuth
for the service provider.
>>>>>>>>>>>>>> I followed the instructions mentioned
in the link you just
>>>>>>>>>>>>>> shared and configured , and added
the client key and  secret key in the
>>>>>>>>>>>>>> pga_config.php.
>>>>>>>>>>>>>> Also, I changed the links in the
email-admin config.xml as
>>>>>>>>>>>>>> you had mentioned.
>>>>>>>>>>>>>> But it looks like the issue did not
resolve. It still fails
>>>>>>>>>>>>>> to send an email.
>>>>>>>>>>>>>> These are how my files look now.
>>>>>>>>>>>>>>
>>>>>>>>>>>>>> On Fri, May 27, 2016 at 5:56 PM,
Jeff <jkinniso@nd.edu>
>>>>>>>>>>>>>> wrote:
>>>>>>>>>>>>>>
>>>>>>>>>>>>>>> It looks like your OAuth client
key and OAuth client secret
>>>>>>>>>>>>>>> in pga_config.php are the defaults--have
you configured OAuth for your
>>>>>>>>>>>>>>> service provider? This page of
the docs has the relevant setup
>>>>>>>>>>>>>>> http://airavata.readthedocs.io/en/latest/WSO2-IS-Configuration/
>>>>>>>>>>>>>>>
>>>>>>>>>>>>>>> Once you have the OAuth service
set up, copy the client key
>>>>>>>>>>>>>>> and secret key that are created
into your pga-config.php.
>>>>>>>>>>>>>>>
>>>>>>>>>>>>>>> The other thing is that the links
in email-admin-config.xml
>>>>>>>>>>>>>>> should be set to something like
>>>>>>>>>>>>>>>
>>>>>>>>>>>>>>>
>>>>>>>>>>>>>>> https://localhost/airavata-php-gateway/public/reset-password?confirmation=
>>>>>>>>>>>>>>> {confirmation-code}&amp;userstoredomain={userstore-domain}&amp;username={url:user-name}&amp;tenantdomain={tenant-domain}
>>>>>>>>>>>>>>>
>>>>>>>>>>>>>>> for Password Reset and
>>>>>>>>>>>>>>>
>>>>>>>>>>>>>>>
>>>>>>>>>>>>>>> https://localhost/airavata-php-gateway/public/confirm-user-registration?confirmation=
>>>>>>>>>>>>>>> {confirmation-code}&amp;userstoredomain={userstore-domain}&amp;username={url:user-name}&amp;tenantdomain={tenant-domain}
>>>>>>>>>>>>>>>
>>>>>>>>>>>>>>> for Account Confirmation. This
points them to the local PGA
>>>>>>>>>>>>>>> pages that handle password reset
and account confirmation, respectively.
>>>>>>>>>>>>>>>
>>>>>>>>>>>>>>> Hope this helps!
>>>>>>>>>>>>>>> Jeff K.
>>>>>>>>>>>>>>>
>>>>>>>>>>>>>>>
>>>>>>>>>>>>>>> On Fri, May 27, 2016 at 5:42
PM, Abhishek Jain <
>>>>>>>>>>>>>>> ajain13@binghamton.edu> wrote:
>>>>>>>>>>>>>>>
>>>>>>>>>>>>>>>>
>>>>>>>>>>>>>>>> Hi All,
>>>>>>>>>>>>>>>>
>>>>>>>>>>>>>>>> I have locally set up the
PGA and WSO2. They are up and
>>>>>>>>>>>>>>>> running. I added the admin
user credentials of the tenant that I created in
>>>>>>>>>>>>>>>> the pga_conf.php file. So
now when I try creating an account, I get a
>>>>>>>>>>>>>>>> message that a confirmation
link has been sent to the email account, but I
>>>>>>>>>>>>>>>> can see an error in my IS
log saying that sending of email has failed which
>>>>>>>>>>>>>>>> is as follows :
>>>>>>>>>>>>>>>>
>>>>>>>>>>>>>>>> *[2016-05-27 14:19:34,698]
@test.bu.com
>>>>>>>>>>>>>>>> <http://test.bu.com>
[1] [IS] INFO
>>>>>>>>>>>>>>>> {org.wso2.carbon.identity.mgt.mail.DefaultEmailSendingModule}
-  Sending
>>>>>>>>>>>>>>>> user credentials configuration
mail to jainabhishek93@gmail.com*
>>>>>>>>>>>>>>>> *[2016-05-27 14:19:35,403]
@test.bu.com
>>>>>>>>>>>>>>>> <http://test.bu.com>
[1] [IS]ERROR
>>>>>>>>>>>>>>>> {org.wso2.carbon.identity.mgt.mail.DefaultEmailSendingModule}
-  Failed
>>>>>>>>>>>>>>>> Sending Email*
>>>>>>>>>>>>>>>> *org.apache.axis2.AxisFault:
Error generating mail message*
>>>>>>>>>>>>>>>> * at
>>>>>>>>>>>>>>>> org.apache.axis2.transport.base.AbstractTransportSender.handleException(AbstractTransportSender.java:226)*
>>>>>>>>>>>>>>>> * at
>>>>>>>>>>>>>>>> org.apache.axis2.transport.mail.MailTransportSender.sendMessage(MailTransportSender.java:184)*
>>>>>>>>>>>>>>>> * at
>>>>>>>>>>>>>>>> org.apache.axis2.transport.base.AbstractTransportSender.invoke(AbstractTransportSender.java:112)*
>>>>>>>>>>>>>>>> * at
>>>>>>>>>>>>>>>> org.apache.axis2.engine.AxisEngine.send(AxisEngine.java:442)*
>>>>>>>>>>>>>>>> * at
>>>>>>>>>>>>>>>> org.apache.axis2.description.OutOnlyAxisOperationClient.executeImpl(OutOnlyAxisOperation.java:297)*
>>>>>>>>>>>>>>>> * at
>>>>>>>>>>>>>>>> org.apache.axis2.client.OperationClient.execute(OperationClient.java:149)*
>>>>>>>>>>>>>>>> * at
>>>>>>>>>>>>>>>> org.apache.axis2.client.ServiceClient.fireAndForget(ServiceClient.java:511)*
>>>>>>>>>>>>>>>> * at
>>>>>>>>>>>>>>>> org.apache.axis2.client.ServiceClient.fireAndForget(ServiceClient.java:488)*
>>>>>>>>>>>>>>>> * at
>>>>>>>>>>>>>>>> org.wso2.carbon.identity.mgt.mail.DefaultEmailSendingModule.sendEmail(DefaultEmailSendingModule.java:116)*
>>>>>>>>>>>>>>>> * at
>>>>>>>>>>>>>>>> org.wso2.carbon.identity.mgt.mail.AbstractEmailSendingModule.notifyUser(AbstractEmailSendingModule.java:59)*
>>>>>>>>>>>>>>>> * at
>>>>>>>>>>>>>>>> org.wso2.carbon.identity.mgt.NotificationSendingModule.run(NotificationSendingModule.java:33)*
>>>>>>>>>>>>>>>> * at
>>>>>>>>>>>>>>>> java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:471)*
>>>>>>>>>>>>>>>> * at
>>>>>>>>>>>>>>>> java.util.concurrent.FutureTask.run(FutureTask.java:262)*
>>>>>>>>>>>>>>>> * at
>>>>>>>>>>>>>>>> java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145)*
>>>>>>>>>>>>>>>> * at
>>>>>>>>>>>>>>>> java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615)*
>>>>>>>>>>>>>>>> * at java.lang.Thread.run(Thread.java:745)*
>>>>>>>>>>>>>>>> *Caused by: org.apache.axis2.AxisFault:
Error creating mail
>>>>>>>>>>>>>>>> message or sending it to
the configured server*
>>>>>>>>>>>>>>>> * at
>>>>>>>>>>>>>>>> org.apache.axis2.transport.base.AbstractTransportSender.handleException(AbstractTransportSender.java:226)*
>>>>>>>>>>>>>>>> * at
>>>>>>>>>>>>>>>> org.apache.axis2.transport.mail.MailTransportSender.sendMail(MailTransportSender.java:505)*
>>>>>>>>>>>>>>>> * at
>>>>>>>>>>>>>>>> org.apache.axis2.transport.mail.MailTransportSender.sendMessage(MailTransportSender.java:175)*
>>>>>>>>>>>>>>>> * ... 14 more*
>>>>>>>>>>>>>>>> *Caused by: javax.mail.AuthenticationFailedException*
>>>>>>>>>>>>>>>> * at javax.mail.Service.connect(Service.java:306)*
>>>>>>>>>>>>>>>> * at javax.mail.Service.connect(Service.java:156)*
>>>>>>>>>>>>>>>> * at javax.mail.Service.connect(Service.java:105)*
>>>>>>>>>>>>>>>> * at javax.mail.Transport.send0(Transport.java:168)*
>>>>>>>>>>>>>>>> * at javax.mail.Transport.send(Transport.java:98)*
>>>>>>>>>>>>>>>> * at
>>>>>>>>>>>>>>>> org.apache.axis2.transport.mail.MailTransportSender.sendMail(MailTransportSender.java:494)*
>>>>>>>>>>>>>>>> * ... 15 more*
>>>>>>>>>>>>>>>>
>>>>>>>>>>>>>>>>
>>>>>>>>>>>>>>>> I am attaching my pga_conf.php
file and also, the
>>>>>>>>>>>>>>>> email-admin-config.xml file.
>>>>>>>>>>>>>>>>
>>>>>>>>>>>>>>>> Also, I am attaching the
screenshots of my tenant details
>>>>>>>>>>>>>>>> and service provider details.
>>>>>>>>>>>>>>>>
>>>>>>>>>>>>>>>> Can you tell me what am I
missing out or if I have made a
>>>>>>>>>>>>>>>> mistake in the pga_config.php
file ?
>>>>>>>>>>>>>>>>
>>>>>>>>>>>>>>>>
>>>>>>>>>>>>>>>> --
>>>>>>>>>>>>>>>> Thanks & Regards,
>>>>>>>>>>>>>>>> Abhishek Jain
>>>>>>>>>>>>>>>>
>>>>>>>>>>>>>>>> *Graduate Student*
>>>>>>>>>>>>>>>> *Department of Computer Science*
>>>>>>>>>>>>>>>> *Thomas J. Watson School
of Engineering & Applied Science*
>>>>>>>>>>>>>>>> *Binghamton University -
State Univeristy of New York
>>>>>>>>>>>>>>>> (SUNY)*
>>>>>>>>>>>>>>>>
>>>>>>>>>>>>>>>>
>>>>>>>>>>>>>>>>
>>>>>>>>>>>>>>>
>>>>>>>>>>>>>>
>>>>>>>>>>>>>>
>>>>>>>>>>>>>> --
>>>>>>>>>>>>>> Thanks & Regards,
>>>>>>>>>>>>>> Abhishek Jain
>>>>>>>>>>>>>>
>>>>>>>>>>>>>> *Graduate Student*
>>>>>>>>>>>>>> *Department of Computer Science*
>>>>>>>>>>>>>> *Thomas J. Watson School of Engineering
& Applied Science*
>>>>>>>>>>>>>> *Binghamton University - State Univeristy
of New York (SUNY)*
>>>>>>>>>>>>>>
>>>>>>>>>>>>>>
>>>>>>>>>>>>>>
>>>>>>>>>>>>>>
>>>>>>>>>>>>>
>>>>>>>>>>>>>
>>>>>>>>>>>>> --
>>>>>>>>>>>>> Thanks & Regards,
>>>>>>>>>>>>> Abhishek Jain
>>>>>>>>>>>>>
>>>>>>>>>>>>> *Graduate Student*
>>>>>>>>>>>>> *Department of Computer Science*
>>>>>>>>>>>>> *Thomas J. Watson School of Engineering
& Applied Science*
>>>>>>>>>>>>> *Binghamton University - State Univeristy
of New York (SUNY)*
>>>>>>>>>>>>>
>>>>>>>>>>>>>
>>>>>>>>>>>>>
>>>>>>>>>>>>
>>>>>>>>>>>>
>>>>>>>>>>>> --
>>>>>>>>>>>> Thanks & Regards,
>>>>>>>>>>>> Abhishek Jain
>>>>>>>>>>>>
>>>>>>>>>>>> *Graduate Student*
>>>>>>>>>>>> *Department of Computer Science*
>>>>>>>>>>>> *Thomas J. Watson School of Engineering &
Applied Science*
>>>>>>>>>>>> *Binghamton University - State Univeristy
of New York (SUNY)*
>>>>>>>>>>>>
>>>>>>>>>>>>
>>>>>>>>>>>>
>>>>>>>>>>>
>>>>>>>>>>
>>>>>>>>>> --
>>>>>>>>>> Thanks & Regards,
>>>>>>>>>> Abhishek Jain
>>>>>>>>>>
>>>>>>>>>> *Graduate Student*
>>>>>>>>>> *Department of Computer Science*
>>>>>>>>>> *Thomas J. Watson School of Engineering & Applied
Science*
>>>>>>>>>> *Binghamton University - State University of New
York (SUNY)*
>>>>>>>>>>
>>>>>>>>>>
>>>>>>>>>>
>>>>>>>>>>
>>>>>>>>>
>>>>>>>>> --
>>>>>>>>> Thanks & Regards,
>>>>>>>>> Abhishek Jain
>>>>>>>>>
>>>>>>>>> *Graduate Student*
>>>>>>>>> *Department of Computer Science*
>>>>>>>>> *Thomas J. Watson School of Engineering & Applied
Science*
>>>>>>>>> *Binghamton University - State University of New York
(SUNY)*
>>>>>>>>>
>>>>>>>>>
>>>>>>>>>
>>>>>>>>>
>>>>>>>
>>>>>>>
>>>>>>> --
>>>>>>> Thanks & Regards,
>>>>>>> Abhishek Jain
>>>>>>>
>>>>>>> *Graduate Student*
>>>>>>> *Department of Computer Science*
>>>>>>> *Thomas J. Watson School of Engineering & Applied Science*
>>>>>>> *Binghamton University - State Univeristy of New York (SUNY)*
>>>>>>>
>>>>>>>
>>>>>>>
>>>>>>
>>>>>
>>>>>
>>>>> --
>>>>> Thanks & Regards,
>>>>> Abhishek Jain
>>>>>
>>>>> *Graduate Student*
>>>>> *Department of Computer Science*
>>>>> *Thomas J. Watson School of Engineering & Applied Science*
>>>>> *Binghamton University - State University of New York (SUNY)*
>>>>>
>>>>>
>>>>>
>>>
>>> --
>>> Thanks & Regards,
>>> Abhishek Jain
>>>
>>> *Graduate Student*
>>> *Department of Computer Science*
>>> *Thomas J. Watson School of Engineering & Applied Science*
>>> *Binghamton University - State University of New York (SUNY)*
>>>
>>>
>>>
>>>
>>
>

-- 
Thanks & Regards,
Abhishek Jain

*Graduate Student*
*Department of Computer Science*
*Thomas J. Watson School of Engineering & Applied Science*
*Binghamton University - State University of New York (SUNY)*

Mime
View raw message