airavata-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Supun Nakandala <supun.nakand...@gmail.com>
Subject Re: "Something went wrong message" during account confirmation on locally installed PGA
Date Fri, 03 Jun 2016 15:23:29 GMT
Yes that works for me.

On Fri, Jun 3, 2016 at 11:21 AM, Abhishek Jain <ajain13@binghamton.edu>
wrote:

> Sure Supun, that would be great !
> How about we have a hangout after exactly 2 hours exact timing being 1:20
> pm (US time). Does that sound good to you ?
>
>
> On Friday, June 3, 2016, Supun Nakandala <supun.nakandala@gmail.com>
> wrote:
>
>> Hi Abhishek,
>>
>> If you still have this issue we can a hangout and try to fix this issue
>> today. Let me know the time that you are free.
>>
>> On Thu, Jun 2, 2016 at 1:42 PM, Supun Nakandala <
>> supun.nakandala@gmail.com> wrote:
>>
>>> I would suggest that you debug and find out the actual error message is
>>> thrown from PGA side. Failed Sending Account Confirmation Email after
>>> Account Creation with local PGA - WSO2 IS set up is a user friendly message
>>> shown for users. If I can know actual error message I can help you.
>>>
>>>
>>> On Thu, Jun 2, 2016 at 1:40 PM, Abhishek Jain <ajain13@binghamton.edu>
>>> wrote:
>>>
>>>> Hi Supun,
>>>> So is there a problem in the account confirmation link which is
>>>> creating the issue ? As fixing the link the way you mentioned gave me the
>>>> same message.
>>>> Should I share my email-admin-config.xml and pga_config.php file with
>>>> you ?
>>>>
>>>> On Thu, Jun 2, 2016 at 11:33 AM, Abhishek Jain <ajain13@binghamton.edu>
>>>> wrote:
>>>>
>>>>> I changed it. I am getting the same error message.
>>>>>
>>>>> On Thu, Jun 2, 2016 at 11:03 AM, Supun Nakandala <
>>>>> supun.nakandala@gmail.com> wrote:
>>>>>
>>>>>> Please change the account confirmation email template in your wso2
IS
>>>>>> to contain this email link
>>>>>> http://localhost/airavata-php-gateway/public/
>>>>>> <http://localhost/airavata-php-gateway/public/confirm-user-registration?confirmation=87348d48-c6c7-44a3-87d2-39ed3bb7e439&userstoredomain=PRIMARY&username=jainabhishek99&tenantdomain=test.bu.com>
>>>>>> confirm-user-registration?confirmation={confirmation-code}&username={user-name}
>>>>>>
>>>>>> On Thu, Jun 2, 2016 at 10:56 AM, Abhishek Jain <
>>>>>> ajain13@binghamton.edu> wrote:
>>>>>>
>>>>>>> Hi Supun,
>>>>>>> I do not see any error log in the wso2 IS. The last update in
the
>>>>>>> log is as follows :
>>>>>>>
>>>>>>> [2016-06-02 10:51:59,306] @test.bu.com [1] [IS] INFO
>>>>>>> {org.wso2.carbon.identity.mgt.mail.DefaultEmailSendingModule}
-  Sending
>>>>>>> user credentials configuration mail to jainabhishek93@gmail.com
>>>>>>> [2016-06-02 10:52:01,322] @test.bu.com [1] [IS] INFO
>>>>>>> {org.wso2.carbon.identity.mgt.mail.DefaultEmailSendingModule}
-  User
>>>>>>> credentials configuration mail has been sent to
>>>>>>> jainabhishek93@gmail.com
>>>>>>>
>>>>>>> I did get a confirmation link. I get the above mentioned "something
>>>>>>> went wrong" message when I visit the link and there are no updates
in the
>>>>>>> wso2 IS log.
>>>>>>>
>>>>>>> On Wed, Jun 1, 2016 at 9:40 PM, Supun Nakandala <
>>>>>>> supun.nakandala@gmail.com> wrote:
>>>>>>>
>>>>>>>> Can you send the error log that you get wso2 IS.
>>>>>>>>
>>>>>>>> On Wed, Jun 1, 2016 at 5:27 PM, Abhishek Jain <
>>>>>>>> ajain13@binghamton.edu> wrote:
>>>>>>>>
>>>>>>>>> Hi Devs,
>>>>>>>>> I have locally installed PGA and WSO2 IS server. Everything
is up
>>>>>>>>> and running. Once I create an account, I do get a account
confirmation link
>>>>>>>>> back from the locally installed WSO2 server.
>>>>>>>>>
>>>>>>>>> The link looks like :
>>>>>>>>>
>>>>>>>>>
>>>>>>>>> http://localhost/airavata-php-gateway/public/confirm-user-registration?confirmation=87348d48-c6c7-44a3-87d2-39ed3bb7e439&userstoredomain=PRIMARY&username=jainabhishek99&tenantdomain=test.bu.com
>>>>>>>>>
>>>>>>>>> But now, when I visit the link, I am getting the following
message
>>>>>>>>> :
>>>>>>>>>
>>>>>>>>> "Looks like something went wrong. Please go back and
try again or
>>>>>>>>> report the problem using help feature."
>>>>>>>>>
>>>>>>>>> This problem is mentioned in the previous thread with
subject :
>>>>>>>>>
>>>>>>>>> Failed Sending Account Confirmation Email after Account
Creation
>>>>>>>>> with local PGA - WSO2 IS set up
>>>>>>>>>
>>>>>>>>> I wanted to start a new thread with this problem.
>>>>>>>>>
>>>>>>>>> I have attached the screenshot below.
>>>>>>>>> --
>>>>>>>>> Thanks & Regards,
>>>>>>>>> Abhishek Jain
>>>>>>>>>
>>>>>>>>> *Graduate Student*
>>>>>>>>> *Department of Computer Science*
>>>>>>>>> *Thomas J. Watson School of Engineering & Applied
Science*
>>>>>>>>> *Binghamton University - State University of New York
(SUNY)*
>>>>>>>>>
>>>>>>>>>
>>>>>>>>>
>>>>>>>>
>>>>>>>>
>>>>>>>> --
>>>>>>>> Thank you
>>>>>>>> Supun Nakandala
>>>>>>>> Dept. Computer Science and Engineering
>>>>>>>> University of Moratuwa
>>>>>>>>
>>>>>>>
>>>>>>>
>>>>>>>
>>>>>>> --
>>>>>>> Thanks & Regards,
>>>>>>> Abhishek Jain
>>>>>>>
>>>>>>> *Graduate Student*
>>>>>>> *Department of Computer Science*
>>>>>>> *Thomas J. Watson School of Engineering & Applied Science*
>>>>>>> *Binghamton University - State University of New York (SUNY)*
>>>>>>>
>>>>>>>
>>>>>>>
>>>>>>
>>>>>>
>>>>>> --
>>>>>> Thank you
>>>>>> Supun Nakandala
>>>>>> Dept. Computer Science and Engineering
>>>>>> University of Moratuwa
>>>>>>
>>>>>
>>>>>
>>>>>
>>>>> --
>>>>> Thanks & Regards,
>>>>> Abhishek Jain
>>>>>
>>>>> *Graduate Student*
>>>>> *Department of Computer Science*
>>>>> *Thomas J. Watson School of Engineering & Applied Science*
>>>>> *Binghamton University - State University of New York (SUNY)*
>>>>>
>>>>>
>>>>>
>>>>
>>>>
>>>> --
>>>> Thanks & Regards,
>>>> Abhishek Jain
>>>>
>>>> *Graduate Student*
>>>> *Department of Computer Science*
>>>> *Thomas J. Watson School of Engineering & Applied Science*
>>>> *Binghamton University - State University of New York (SUNY)*
>>>>
>>>>
>>>>
>>>
>>>
>>> --
>>> Thank you
>>> Supun Nakandala
>>> Dept. Computer Science and Engineering
>>> University of Moratuwa
>>>
>>
>>
>>
>> --
>> Thank you
>> Supun Nakandala
>> Dept. Computer Science and Engineering
>> University of Moratuwa
>>
>
>
> --
> Thanks & Regards,
> Abhishek Jain
>
> *Graduate Student*
> *Department of Computer Science*
> *Thomas J. Watson School of Engineering & Applied Science*
> *Binghamton University - State University of New York (SUNY)*
>
>
>
>


-- 
Thank you
Supun Nakandala
Dept. Computer Science and Engineering
University of Moratuwa

Mime
View raw message