airavata-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jeff <jkinn...@nd.edu>
Subject Re: WSO2 User Reg Confirmation
Date Wed, 11 May 2016 12:43:53 GMT
Sure. Confirmation seems to be working now, I just can't log in with the 
confirmed accounts. I get a second email (at the admin email address) 
saying that the new account was created after clicking the link in the 
confirmation email.

ID: [-1] [] [2016-05-11 08:39:29,516]  WARN 
{org.apache.directory.shared.asn1.ber.Asn1Decoder} -  The PDU has been 
fully decoded but there are still bytes in the buffer.
TID: [-1234] [] [2016-05-11 08:39:29,521]  INFO 
{org.wso2.carbon.user.core.ldap.ReadWriteLDAPUserStoreManager} - LDAP 
connection created successfully in read-write mode
TID: [1] [] [2016-05-11 08:39:29,595] master@master.airavata [1] [IS] 
INFO {org.wso2.carbon.core.services.util.CarbonAuthenticationUtil} - 
'master@master.airavata [1]' logged in at [2016-05-11 08:39:29,594-0400]
TID: [1] [] [2016-05-11 08:39:29,604] master@master.airavata [1] [IS] 
INFO {org.wso2.carbon.core.multitenancy.TenantAxisConfigurator} -  
Creating tenant AxisConfiguration for tenant: master.airavata[1]
TID: [1] [] [2016-05-11 08:39:29,650] master@master.airavata [1] [IS] 
INFO 
{org.wso2.carbon.identity.user.store.configuration.deployer.UserStoreConfigurationDeployer}

-  User Store Configuration Deployer initiated.
TID: [1] [] [2016-05-11 08:39:29,651] master@master.airavata [1] [IS] 
INFO 
{org.wso2.carbon.identity.user.store.configuration.deployer.UserStoreConfigurationDeployer}

-  User Store Configuration Deployer initiated.
TID: [1] [] [2016-05-11 08:39:29,651] master@master.airavata [1] [IS] 
INFO {org.wso2.carbon.bpel.deployer.BPELDeployer} - Initializing BPEL 
Deployer for tenant 1.
TID: [1] [] [2016-05-11 08:39:29,652] master@master.airavata [1] [IS] 
INFO {org.wso2.carbon.humantask.deployer.HumanTaskDeployer} - 
Initializing HumanTask Deployer for tenant 1.
TID: [1] [] [2016-05-11 08:39:29,678] master@master.airavata [1] [IS] 
INFO {org.wso2.carbon.core.internal.permission.update.PermissionUpdater} 
-  Permission cache updated for tenant 1
TID: [1] [] [2016-05-11 08:39:29,693] @master.airavata [1] [IS] INFO 
{org.wso2.carbon.core.deployment.DeploymentInterceptor} -  Deploying 
Axis2 service: wso2carbon-sts {master.airavata[1]}
TID: [1] [] [2016-05-11 08:39:29,706] master@master.airavata [1] [IS] 
INFO {org.apache.axis2.deployment.DeploymentEngine} - Deploying Web 
service: org.wso2.carbon.sts -
TID: [1] [] [2016-05-11 08:39:29,708] @master.airavata [1] [IS] INFO 
{org.wso2.carbon.core.deployment.DeploymentInterceptor} -  Deploying 
Axis2 service: wso2carbon-sts {master.airavata[1]}
TID: [1] [] [2016-05-11 08:39:29,716] master@master.airavata [1] [IS] 
INFO {org.wso2.carbon.core.multitenancy.utils.TenantAxisUtils} -  Loaded 
tenant master.airavata in 118 ms
TID: [1] [] [2016-05-11 08:39:29,847] master@master.airavata [1] [IS] 
INFO {org.wso2.carbon.core.services.util.CarbonAuthenticationUtil} - 
'master@master.airavata [1]' logged in at [2016-05-11 08:39:29,847-0400]
TID: [1] [] [2016-05-11 08:39:30,058] @master.airavata [1] [IS] INFO 
{org.wso2.carbon.identity.mgt.mail.DefaultEmailSendingModule} - Sending 
user credentials configuration mail to jkinniso@nd.edu
TID: [-1] [] [2016-05-11 08:39:30,103]  WARN 
{org.apache.directory.shared.asn1.ber.Asn1Decoder} -  The PDU has been 
fully decoded but there are still bytes in the buffer.
TID: [1] [] [2016-05-11 08:39:32,350] @master.airavata [1] [IS] INFO 
{org.wso2.carbon.identity.mgt.mail.DefaultEmailSendingModule} - User 
credentials configuration mail has been sent to jkinniso@nd.edu
TID: [1] [] [2016-05-11 08:40:37,196] master@master.airavata [1] [IS] 
INFO {org.wso2.carbon.core.services.util.CarbonAuthenticationUtil} - 
'master@master.airavata [1]' logged in at [2016-05-11 08:40:37,196-0400]
TID: [1] [] [2016-05-11 08:40:37,382] master@master.airavata [1] [IS] 
INFO {org.wso2.carbon.core.services.util.CarbonAuthenticationUtil} - 
'master@master.airavata [1]' logged in at [2016-05-11 08:40:37,382-0400]


On 05/11/2016 01:40 AM, Supun Nakandala wrote:
> Hi Jeff,
>
> Can you share last few lines in your wso2carbon.log file.
>
> On Tue, May 10, 2016 at 1:20 PM, Jeff <jkinniso@nd.edu 
> <mailto:jkinniso@nd.edu>> wrote:
>
>     Okay, so by setting Captcha.Verification.Internally.Managed=false
>     in <WSO2_home>/repository/conf/identity/identity-mgt.properties, I
>     was able to get around the "Captcha validation failed!" issue.
>
>     However, I can't log in with this account now, and the user didn't
>     seem to be created. I just tried again with the same result. So
>     the conundrum is now this: I can create users without Captcha but
>     can't log them in, or I can use Captach and run into the issue
>     where new users can't be created.
>
>     Jeff K.
>
>     On 05/10/2016 03:28 PM, Supun Nakandala wrote:
>>
>>     Yes. It gets logged in IS-HOME/repository/logs/wso2carbon.log.
>>     can you check what is the error there ?
>>
>>     On May 10, 2016 12:25 PM, "Jeff" <jkinniso@nd.edu
>>     <mailto:jkinniso@nd.edu>> wrote:
>>
>>         Okay, I changed my email configuration in WSO2IS to send http
>>         links instead of https, but now I get the message "Account
>>         confirmation failed!" every time with no explanation as to
>>         why. Would that information be logged anywhere?
>>
>>         At this point, I'm beginning to wonder if I should just start
>>         again from scratch.
>>
>>         Jeff K.
>>
>>
>>         On 05/10/2016 12:44 PM, Supun Nakandala wrote:
>>>         the link shouldn't have :9443 or any other port. It should
>>>         be set blank defaulting to port 80 (your web server port).
>>>         Can you try the link
>>>         http://localhost/airavata-php-gateway/public/confirm-user-registration?confirmation=6d9dbd05-8886-4056-8e8d-11d20dfa3714&userstoredomain=PRIMARY&username=jkinniso&tenantdomain=master.airavata
>>>         <https://localhost/airavata-php-gateway/public/confirm-user-registration?confirmation=6d9dbd05-8886-4056-8e8d-11d20dfa3714&userstoredomain=PRIMARY&username=zerothehero33&tenantdomain=master.airavata>
in
>>>         the email template and retry user creation.
>>>
>>>         On Tue, May 10, 2016 at 9:32 AM, Jeff <jkinniso@nd.edu
>>>         <mailto:jkinniso@nd.edu>> wrote:
>>>
>>>             Ah, I just got it: https requests aren't going through.
>>>             I can access the pages through http protocol, but not
>>>             https. Any thoughts on what to do here?
>>>
>>>
>>>             On 05/10/2016 12:22 PM, Supun Nakandala wrote:
>>>>             Hi Jeff,
>>>>
>>>>             Can you send me the url for the home page in your local
>>>>             PGA.
>>>>
>>>>             On Tue, May 10, 2016 at 9:20 AM, Eroma Abeysinghe
>>>>             <eroma.abeysinghe@gmail.com
>>>>             <mailto:eroma.abeysinghe@gmail.com>> wrote:
>>>>
>>>>                 Hi Jeff,
>>>>
>>>>                 Can you try another user registration but first in
>>>>                 WSO2 ID email templates remove the 'public'
>>>>                 so it should look like
>>>>
>>>>                 https://localhost/airavata-php-gateway/confirm-user-registration?confirmation=6d9dbd05-8886-4056-8e8d-11d20dfa3714&userstoredomain=PRIMARY&username=jkinniso&tenantdomain=master.airavata
>>>>                 <https://localhost/airavata-php-gateway/public/confirm-user-registration?confirmation=6d9dbd05-8886-4056-8e8d-11d20dfa3714&userstoredomain=PRIMARY&username=zerothehero33&tenantdomain=master.airavata>
>>>>
>>>>                 Thanks,
>>>>                 Eroma
>>>>
>>>>                 On Tue, May 10, 2016 at 12:13 PM, Jeff
>>>>                 <jkinniso@nd.edu <mailto:jkinniso@nd.edu>> wrote:
>>>>
>>>>                     Hi Eroma,
>>>>
>>>>                     Yes to both of those questions. The url looks like
>>>>
>>>>                     https://localhost/airavata-php-gateway/public/confirm-user-registration?confirmation=6d9dbd05-8886-4056-8e8d-11d20dfa3714&userstoredomain=PRIMARY&username=jkinniso&tenantdomain=master.airavata
>>>>                     <https://localhost/airavata-php-gateway/public/confirm-user-registration?confirmation=6d9dbd05-8886-4056-8e8d-11d20dfa3714&userstoredomain=PRIMARY&username=zerothehero33&tenantdomain=master.airavata>
>>>>
>>>>                     When I clicked this link (when it was first
>>>>                     sent), I was told that the server couldn't be
>>>>                     found. However, everything is running. That's
>>>>                     why I was asking about the url, because I'm not
>>>>                     sure that it's actually correct. This points to
>>>>                     my PGA installation, and I got the
>>>>                     confirm-user-registration part from routes.php
>>>>                     in the PGA.
>>>>
>>>>                     Best,
>>>>                     Jeff K.
>>>>
>>>>
>>>>                     On 05/10/2016 11:53 AM, Eroma Abeysinghe wrote:
>>>>>                     Hi Jeff,
>>>>>
>>>>>                     Hmmm.....
>>>>>                     you might have done this as well...
>>>>>                     1. is the link in email correct for account
>>>>>                     confirmation? Does it contain your PGA URL?
>>>>>                     2. Can you log into your WSO2 using tenant
>>>>>                     username and password?
>>>>>
>>>>>                     Hope my questions would help.
>>>>>
>>>>>                     Thanks,
>>>>>                     Eroma
>>>>>
>>>>>
>>>>>
>>>>>                     ‚Äč
>>>>>
>>>>>                     On Tue, May 10, 2016 at 11:35 AM, Jeffery
>>>>>                     Kinnison <Jeffery.D.Kinnison.1@nd.edu
>>>>>                     <mailto:Jeffery.D.Kinnison.1@nd.edu>> wrote:
>>>>>
>>>>>                         Hi Eroma,
>>>>>
>>>>>                         Yes, I followed the directions in the
>>>>>                         ReadTheDocs and set up WSO2-IS as close to
>>>>>                         this as I could find--I'm using WSO2-IS
>>>>>                         5.1.0, and it doesn't look exactly the
>>>>>                         same as what the ReadTheDocs describes but
>>>>>                         all of the described settings still exist.
>>>>>
>>>>>                         Best,
>>>>>                         Jeff K.
>>>>>
>>>>>
>>>>>
>>>>>
>>>>>
>>>>>                         On Tue, May 10, 2016 at 11:24 AM, Eroma
>>>>>                         Abeysinghe <eroma.abeysinghe@gmail.com
>>>>>                         <mailto:eroma.abeysinghe@gmail.com>>
wrote:
>>>>>
>>>>>                             Hi Jeff,
>>>>>
>>>>>                             If you haven't already got this check
>>>>>                             this out as well
>>>>>                             http://airavata.readthedocs.io/en/latest/WSO2-IS-Configuration/
>>>>>
>>>>>                             Thanks,
>>>>>                             Eroma
>>>>>
>>>>>                             On Tue, May 10, 2016 at 11:20 AM,
>>>>>                             Eroma Abeysinghe
>>>>>                             <eroma.abeysinghe@gmail.com
>>>>>                             <mailto:eroma.abeysinghe@gmail.com>>
>>>>>                             wrote:
>>>>>
>>>>>                                 Hi Jeff,
>>>>>
>>>>>                                 Did you create a tenant for your
>>>>>                                 PGA? or are you using the default
>>>>>                                 that was in PGA_Config?
>>>>>                                 Could you please share the
>>>>>                                 identity server URL you are using?
>>>>>
>>>>>                                 Thanks,
>>>>>                                 Eroma
>>>>>
>>>>>                                 On Tue, May 10, 2016 at 11:05 AM,
>>>>>                                 Jeff <jkinniso@nd.edu
>>>>>                                 <mailto:jkinniso@nd.edu>> wrote:
>>>>>
>>>>>                                     I'm finishing up my
>>>>>                                     development environment so I
>>>>>                                     can work on some JIRA issues
>>>>>                                     during the remaining community
>>>>>                                     bonding period (GSoC project),
>>>>>                                     and am stuck at user
>>>>>                                     confirmation on my local PGA.
>>>>>
>>>>>                                     After creating an account, the
>>>>>                                     account confirmation email
>>>>>                                     gets sent. However, clicking
>>>>>                                     the link in the email does
>>>>>                                     nothing. In
>>>>>                                     email-admin-config.xml in my
>>>>>                                     local WSO2, I tried the
>>>>>                                     default link
>>>>>                                     (|https://localhost:8443/InfoRecoverySample/confirmReg?confirmation={confirmation-code}&amp;userName={user-name}|_&amp;tenantdomain={tenant-domain}_),
>>>>>                                     changing the default link t
>>>>>                                     use port 9443
>>>>>                                     (|https://localhost:9443/InfoRecoverySample/confirmReg?confirmation={confirmation-code}&amp;userName={user-name}|_&amp;tenantdomain={tenant-domain}_),
>>>>>                                     and changing to the confirm
>>>>>                                     account view on the PGA
>>>>>                                     (_https://localhost/airavata-php-gateway/public/confirm-user-registration?confirmation={confirmation-code}&amp;userstoredomain={userstore-domain}&amp;username={url:user-name}&amp;tenantdomain={tenant-domain}_),
>>>>>                                     but none of these work. Does
>>>>>                                     anyone have any suggestions?
>>>>>
>>>>>                                     Also, is there a default admin
>>>>>                                     account for the PGA? So far, I
>>>>>                                     haven't seen any indication of
>>>>>                                     one, and using the WSO2 tenant
>>>>>                                     admin credentials in the PGA
>>>>>                                     doesn't work either.
>>>>>
>>>>>                                     Best,
>>>>>                                     Jeff K.
>>>>>
>>>>>
>>>>>
>>>>>
>>>>>                                 -- 
>>>>>                                 Thank You,
>>>>>                                 Best Regards,
>>>>>                                 Eroma
>>>>>
>>>>>
>>>>>
>>>>>
>>>>>                             -- 
>>>>>                             Thank You,
>>>>>                             Best Regards,
>>>>>                             Eroma
>>>>>
>>>>>
>>>>>
>>>>>
>>>>>
>>>>>                     -- 
>>>>>                     Thank You,
>>>>>                     Best Regards,
>>>>>                     Eroma
>>>>
>>>>
>>>>
>>>>
>>>>                 -- 
>>>>                 Thank You,
>>>>                 Best Regards,
>>>>                 Eroma
>>>>
>>>>
>>>>
>>>>
>>>>             -- 
>>>>             Thank you
>>>>             Supun Nakandala
>>>>             Dept. Computer Science and Engineering
>>>>             University of Moratuwa
>>>
>>>
>>>
>>>
>>>         -- 
>>>         Thank you
>>>         Supun Nakandala
>>>         Dept. Computer Science and Engineering
>>>         University of Moratuwa
>>
>
>
>
>
> -- 
> Thank you
> Supun Nakandala
> Dept. Computer Science and Engineering
> University of Moratuwa


Mime
View raw message