airavata-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Pankaj Saha <psa...@binghamton.edu>
Subject Re: Unable to instantiate Airavata Client
Date Fri, 26 Jun 2015 02:33:47 GMT
Hi Lahiru

Isn't it running all of them in --net=host mode will make all the
containers as different applications running on same host?
Though I have tried running all of them in --net=host  mode and I believe
its not creating separate host(ip) for each docker containers.
I have confirmed that by inspecting each containers (docker inspect
container_name). They don't have any separate ip address associated with
it, which makes them an application in the local host.

I am able to do "nc -zv localhost 8930" and its connecting successfully. So
I believe its problem with docker containers or some issue with the exposed
ports.

Thanks
Pankaj



On Thu, Jun 25, 2015 at 7:35 PM, Lahiru Ginnaliya Gamathige <
glahiru@gmail.com> wrote:

> I recommend not to use --link and use environment variables. For now you
> can do a quick test with --net=host. People do not use --link in production
> and we will not use either because it only works in single host scenario.
>
>
> On Thu, Jun 25, 2015 at 4:25 PM, Pankaj Saha <psaha4@binghamton.edu>
> wrote:
>
>> Yes all docker containers are on the same host and connected through
>> --link option. With link option i have tested airavata and rabbit mq and
>> they are working fine. Prob is with airavata pga and airavata server. API
>> server is running on 8930 which is refusing connection while pga tries to
>> access. So in some situation docker link is working and not other case. I
>> have exposed 8930 8940 8950 none of them are listening .
>>
> How did you expose these ports ? Are these open in the host environment ?
>
> Lahiru
>
>> On 25-Jun-2015 7:19 PM, "Lahiru Ginnaliya Gamathige" <glahiru@gmail.com>
>> wrote:
>>
>>> If this worked yes then this is something to do with docker. Ideally to
>>> solve this kind of an issue you can either use --link option of docker but
>>> this will only work when you run all the containers in the same host. But
>>> if you are running in different hosts and they have to be connected what
>>> people usually do is reading these host information via environment
>>> variable. You can set default values to your dockerfile and always can
>>> overwrite them when you do docker run with -e option.
>>>
>>> Regards
>>> Lahiru
>>>
>>> On Thu, Jun 25, 2015 at 4:15 PM, Lahiru Ginnaliya Gamathige <
>>> glahiru@gmail.com> wrote:
>>>
>>>> You can quickly test whether this is a docker issue or not by running
>>>> all the containers with --net=host, it will directly give you the host
>>>> network environment for all of your containers.
>>>>
>>>> On Thu, Jun 25, 2015 at 3:03 PM, Pankaj Saha <psaha4@binghamton.edu>
>>>> wrote:
>>>>
>>>>> Hi Suresh,
>>>>>
>>>>> Looks like its an issue with airavata server , which does allow
>>>>> external requests to access its ports. I believe its due to docker which
>>>>> some how protecting the airavata ports to external requests and
>>>>> intentionally refusing the connection.
>>>>>
>>>>> I have tested with three dockers
>>>>> 1. Airavta PGA
>>>>> 2. Airavata Server
>>>>> 3. Rabbit MQ server.
>>>>>
>>>>> Rabbit MQ docker is good to expose it's ports and allowing other
>>>>> containers to access it. I am able to access Rabbit MQ from airavata
pga
>>>>> and airavata server container, its working fine.
>>>>>
>>>>> So either its an issue with the way we are exposing the ports or some
>>>>> permission issue inside docker. Until we are able to fix this we can
>>>>> neither release our airavata server docker nor individual server
>>>>> components' docker.
>>>>>
>>>>> I can explain the same tomorrow in demo meeting.
>>>>>
>>>>> Thanks
>>>>> Pankaj
>>>>>
>>>>>
>>>>> On Thu, Jun 25, 2015 at 12:48 PM, Pankaj Saha <psaha4@binghamton.edu>
>>>>> wrote:
>>>>>
>>>>>> after dockerization airavata server, rabbit MQ and airavta PGA are
no
>>>>>> longer running in a same local host, instead they are running in
three
>>>>>> separate dockers.
>>>>>> airavata server needs rabbit MQ and its able to connect to the docker
>>>>>> container which contains the rabbit MQ iat the container port.
>>>>>> But problem arises when PGA tries to connect to the airavata server
>>>>>> at its specific port(server:8930)
>>>>>> its saying "unable to instantiate a client"  in
>>>>>> *AiravataServiceProvider.php* file because of network connection
>>>>>> issue.
>>>>>>
>>>>>> anyone has any idea why its not connecting to pga??
>>>>>>
>>>>>>
>>>>>>
>>>>>>
>>>>>> On Wed, Jun 24, 2015 at 6:43 PM, Pankaj Saha <psaha4@binghamton.edu>
>>>>>> wrote:
>>>>>>
>>>>>>>  This is a very known issue when we install airavata server in
our
>>>>>>> local system.
>>>>>>> solution is: we have to change the airvata-server and port in
>>>>>>> config_pga and airavata properties file to establish connection
between
>>>>>>> these two servers.
>>>>>>>
>>>>>>> I m facing this same issue when installing the same in two different
>>>>>>> dockers. Even after changing the server address and port number
its still
>>>>>>> saying unable to instantiate airavata client.
>>>>>>>
>>>>>>> I have verified the default gateway id is 'default' in both the
>>>>>>> places.
>>>>>>>
>>>>>>> any one has any idea??
>>>>>>>
>>>>>>> this is my last step to dockerizing the whole airavata application.
>>>>>>>
>>>>>>> Thanks
>>>>>>> Pankaj
>>>>>>>
>>>>>>
>>>>>>
>>>>>
>>>>
>>>
>

Mime
View raw message