airavata-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From John Weachock <jweach...@gmail.com>
Subject Re: Error creating account on self-hosted PGA
Date Wed, 10 Jun 2015 16:05:10 GMT
*~/airavata-php-gateway » openssl version
*OpenSSL 1.0.2a 19 Mar 2015*~/airavata-php-gateway » php --version
*PHP 5.6.9 (cli) (built: May 15 2015 10:24:33)
Copyright (c) 1997-2015 The PHP Group
Zend Engine v2.6.0, Copyright (c) 1998-2015 Zend Technologies


On Wed, Jun 10, 2015 at 12:02 PM, Supun Nakandala <supun.nakandala@gmail.com
> wrote:

> Hi John,
>
> What is the php version and openssl version that you are using?
>
> On Wed, Jun 10, 2015 at 9:30 PM, John Weachock <jweachock@gmail.com>
> wrote:
>
>> It worked. Thank you, Supun!
>>
>> On Wed, Jun 10, 2015 at 11:59 AM, Supun Nakandala <
>> supun.nakandala@gmail.com> wrote:
>>
>>> Hi John,
>>>
>>> Can you try setting peer_name instead of CN_match and try
>>>
>>> https://github.com/apache/airavata-php-gateway/blob/master/app/libraries/Wsis/Wsis.php#L55
>>>
>>>
>>> On Wed, Jun 10, 2015 at 9:00 PM, John Weachock <jweachock@gmail.com>
>>> wrote:
>>>
>>>> Hello,
>>>>
>>>> I received the following error during account creation on a self-hosted
>>>> PGA installation:
>>>>
>>>> ErrorException (E_DEPRECATED): the 'CN_match' SSL context option is
>>>> deprecated in favor of 'peer_name'
>>>>
>>>> Does anyone know what's causing this error or how to fix it?
>>>>
>>>> Thanks,
>>>>
>>>> John
>>>>
>>>
>>>
>>>
>>> --
>>> Thank you
>>> Supun Nakandala
>>> Dept. Computer Science and Engineering
>>> University of Moratuwa
>>>
>>
>>
>
>
> --
> Thank you
> Supun Nakandala
> Dept. Computer Science and Engineering
> University of Moratuwa
>

Mime
View raw message