airavata-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Hasini Gunasinghe <hasi7...@gmail.com>
Subject Resolving the issues in the Airavata server statup
Date Mon, 16 Mar 2015 06:54:12 GMT
Hi Devs,

I tried starting the Airavata server after building from source (tried both
master branch and 0.14_release). I see the following errors printed on the
start up console.
I am not sure if they are local to me.
I would appreciate any insight on resolving them.

1). [INFO] Reading snapshot data/version-2/snapshot.35
[INFO] Snapshotting: 4f
Mon Mar 16 02:12:28 EDT 2015 : Could not listen on port 1527 on host 0.0.0.0
:
 java.net.BindException: Address already in use
[INFO] Database already created for Registry!

However, when I did netstat after shutting down the airavata server, port
1527 is not in used. Is this something that we could ignore?

2). [ERROR] Cannot connect to a RabbitMQ Server:
java.net.ConnectException: Connection refused

I understand that this is because I have not run RabbitMQ server. I had
some issues installing RabbitMQ server in my environment. Is there a way to
start Airavata server without running RabbitMQ separately?

3) [INFO] Starting Gfac Server on Port 8950
[INFO] Listening to Gfac Clients ....
[ERROR] The Credential Store Server did not start!!!

Is there any special configuration for the credential store to start?

Also, could I please know what is the last message that I should see on
server start up console to confirm that the Airavata server started
successfully? (currently I see a set of messages on "Expiring Session.."
and "Processed session termination.." towards the end of the logs printed
in the server start up console.)

Thank you in advance.

Best Regards,
Hasini.

Mime
View raw message