airavata-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Suresh Marru <sma...@apache.org>
Subject Re: Master doesn't compile with JDK 1.7
Date Wed, 25 Mar 2015 17:50:45 GMT
Hi Shameera,

I made this suggestion but did not push the changes to trunk. I tried it locally and it all
worked fine. So I suggest we get back on the thread and if there is an agreement (or no disagreement)
we bump versions and test it all and declare 1.8 is required for Airavata.

Suresh

> On Mar 25, 2015, at 12:45 PM, Shameera Rathnayaka <shameerainfo@gmail.com> wrote:
> 
> Thanks Marlon, ‚ÄčI assume it is confirmed that we will use jdk 1.8.
> 
> Thanks, 
> Shameera.
> 
> On Wed, Mar 25, 2015 at 12:15 PM, Marlon Pierce <marpierc@iu.edu <mailto:marpierc@iu.edu>>
wrote:
> Suresh already raised this issue on another thread: "[DISCUSS] Airavata default support
to Java 8".   Oracle is ending support for Java 7 in April.
> 
> Marlon
> 
> 
> On 3/25/15 12:07 PM, Shameera Rathnayaka wrote:
> Hi Dev,
> 
> I just try to build the master with JDK 1.7 and got a compilation error,
> This commit cb6c4ccf267c165e64d6858584b2300eaaa37df4
> <https://github.com/apache/airavata/commit/cb6c4ccf267c165e64d6858584b2300eaaa37df4
<https://github.com/apache/airavata/commit/cb6c4ccf267c165e64d6858584b2300eaaa37df4>>
> make master only build with JDK 1.8 as it use Long.BYTES which is comes
> with JDK 1.8. Are we planning to move to 1.8 from next release?
> 
> Thanks,
> Shameera.
> 
> 
> 
> 
> 
> -- 
> Best Regards,
> Shameera Rathnayaka.
> 
> email: shameera AT apache.org <http://apache.org/> , shameerainfo AT gmail.com
<http://gmail.com/>
> Blog : http://shameerarathnayaka.blogspot.com/ <http://shameerarathnayaka.blogspot.com/>


Mime
View raw message