airavata-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From SmashRod Alfredo <smash...@hotmail.it>
Subject RE: Exception with local Echo sample test
Date Tue, 04 Nov 2014 16:03:34 GMT
Hi Chathuri,
Thanks for your reply, just an information,
a RabbitMQ server instance is included in the airavata installation (like zookeeper), or it
is necessary to install it separately? I presume I have to install it separately...

Thanks

Alfredo

From: kamalasini@gmail.com
Date: Tue, 4 Nov 2014 10:50:11 -0500
Subject: Re: Exception with local Echo sample test
To: dev@airavata.apache.org

Hi Alfredo, 
If you are using XBaya to run experiments, you need to have rabbitMQ server up and running
in order to xbaya monitoring to work. To configure rabbitMQ with airavata, follow the below
steps. Start RabbitMQ server Stop the running airavata serverIn airavata-server.properties,
change the property "publish.rabbitmq" to true (publish.rabbitmq=true)Start the airavata server
againRun echo experiment from xbaya againLet us know whether this fix your problem. 
Thanks..Chathuri
On Tue, Nov 4, 2014 at 10:05 AM, SmashRod Alfredo <smashrod@hotmail.it> wrote:






Hello everyone,
I've downloaded the latest version from git repository and compiled airavata without test
(I've tried to build it normally but gives me error testing app-catalog module). I managed
to start airavata-server which but gave me some issues about zookeeper and rabbitMQ.

However, the server seems to be running. After that I've tried to create my own experiment
for a simple Echo executed on localhost.
(I skip the calls to registerXSEDEHosts and rregisterGatewayResourceProfile and commented
all the reference to XSEDE resources elsewhere)

The echo application seems to be registered correctly, but when I try to create a simple workflow
through airavata-xbaya (that throws errors about RabbitMQ on start) using the registered echo
it gives me an exception Exception in thread "AWT-EventQueue-0" java.lang.NullPointerException
.

What did I miss? Is it necessary a particular configuration about GatewayResourceProfile for
localhost?

Thanks to all,

Alfredo

 		 	   		  

 		 	   		  
Mime
View raw message