airavata-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Marlon Pierce <marpi...@iu.edu>
Subject Re: [Dev] Unable to start Airavata after the source build
Date Tue, 23 Sep 2014 13:13:53 GMT
Hi Ishara--

I'm glad to hear about your interest.  Getting XBaya integrated back 
with the Thrift API would be a great contribution.  Note also Shameera 
Yodage has been working on this and can clarify if he has any recent 
fixes that need to be committed to master.

You will need to create Jiras if appropriate ones don't exist.  We 
ideally follow the epic-story-subtask pattern.  Epics are collections of 
Jira stories. Jira stories are collections of related tasks (entered as 
Jira subtasks).  Each subtask is a well-defined, closeable problem.  
These should be self describing and prescriptive: after reading a 
subtask description, anyone should be able to close it.

When you complete a subtask, attach your fix as a patch in Jira.

I recommend spending some time first outlining a set of story tasks 
before diving into the code to fix miscellaneous bugs.


Marlon

On 9/23/14, 12:00 AM, ishara premadasa wrote:
> Hi Saminda,
>
> Thanks a lot for the inputs. I have been trying through the suggestions you
> have given above however there are still some roadblocks when getting
> Airavata samples working back. Here are few of the things i noticed.
>
> 1. At the time of Airavata server start there are following error log can
> be seen several time as 'Address already in use'. But server still starts
> fine.
>
> [INFO] Finished starting ZK: State:CONNECTED Timeout:6000
> sessionid:0x148a04560ce0000 local:/127.0.0.1:57593 remoteserver:localhost/
> 127.0.0.1:2181 lastZxid:22 xid:7 sent:8 recv:7 queuedpkts:0 pendingresp:0
> queuedevents:0
> Mon Sep 22 22:09:37 EDT 2014 : Could not listen on port 1527 on host 0.0.0.0
> :
>   java.net.BindException: Address already in use
> [INFO] Database already created for Registry!
>
> 2. In tutorial it says to load the math-service-workflow from WSDL URI, but
> the GUI has no menu option for it.
>
> 3. Tried to run CreateLaunchExperiment class from IDE and register
> applications programmatically, but those are not getting registered under
> localhost. I tried with registering echo module under localhost, but got
> stuck with the below error in middle.
>
> InvalidRequestException(message:Experiment
> 'echoExperiment_0102904b-7266-4cb5-ad1d-7fa3709393b3' launch failed. Unable
> to figureout execution type for application
> SimpleEcho3_b81c2559-a088-42a3-84ce-40119d874918)
>      at
> org.apache.airavata.client.samples.CreateLaunchExperiment.launchExperiment(CreateLaunchExperiment.java:824)
>      at
> org.apache.airavata.client.samples.CreateLaunchExperiment.main(CreateLaunchExperiment.java:83)
>
> I am very happy to contribute in getting the tutorials back to track with
> the 0.14 release. Please advice if i need to create a doc JIRA for this.
> However as i feel we will have to first fix these issues to get the samples
> running.
>
> Thanks!
> Ishara
>
>
> On Wed, Sep 3, 2014 at 12:15 AM, Saminda Wijeratne <samindaw@gmail.com>
> wrote:
>
>> hi Ishara,
>>
>> The quickstart tutorial is out of date as of last 2 releases. You're
>> welcome to create a JIRA to discuss updates to the tutorial.
>>
>> XBaya as a client was discontinued since 0.12 Airavata release due to
>> major architectural and design changes that incurred in the Airavata Server
>> (in short the scope of the features, the internal component architecture,
>> data models, the API and the service layer for the API changed).
>>
>> For 0.14 release we are targeting on a minimum functionality XBaya GUI
>> client that can compose/register/launch workflows (perhaps more).
>> Even-though the XBaya maven module (which you've mentioned) is present in
>> the trunk, the actual maven module which creates the XBaya GUI binary
>> distribution is not yet present in the trunk. You are welcome to create
>> JIRA and provide patches to introduce this module back to the trunk. You
>> may refer a previous revision of Airavata source (before 0.12 release).
>>
>> IMO for the time being simplest solution to run the XBaya GUI is by
>> executing  the org.apache.airavata.xbaya.XBaya class through the IDE.
>>
>>
>>
>> On Tue, Sep 2, 2014 at 10:17 PM, ishara premadasa <idpremadasa@gmail.com>
>> wrote:
>>
>>> Hi Devs,
>>>
>>> I have been trying to build Airavata from the source code using git
>>> repository [1] and after successfully building i tried to run Airavata
>>> server and GUI as mentioned in the tutorial here [2]. The Airavata server
>>> starts fine but when going to start Xbaya GUI using 'xbaya-gui.sh' as the
>>> tutorial says i could notice that it has not been generated there in
>>> Airavata_HOME/modules/xbaya-gui/bin directory.
>>>
>>> Is there anything missing in the source build (0.14-SNAPSHOT) or am i
>>> referring to a wrong location to find this script? May i please know how to
>>> overcome this issue and get the GUI running.
>>>
>>> Thanks!
>>> Ishara
>>>
>>> [1] https://github.com/apache/airavata
>>> [2] https://airavata.apache.org/documentation/quickstart-tutorials.html
>>>
>>> --
>>> *Best Regards.*
>>>
>>> *Ishara Premadasa,*
>>> http://isharapremadasa.blogspot.com
>>>
>>>
>>>
>


Mime
View raw message