airavata-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Raminder Singh <raminderjsi...@gmail.com>
Subject Re: jglobus dependency in modules
Date Thu, 23 May 2013 14:28:34 GMT
You should definitely remove from workflow-model*.  

xbaya-gui: Workflow interpreter set the GSISecurity context to context header while calling
GFAC API. That's where we may be using it. I am sure resolve this dependency using credential
store and remove it. 
apache-airavata-server: is the distribution project so we need it there. 
apache-airavata-client: I am not sure
test-suite: i think you can. 
 
Thanks
Raminder

On May 23, 2013, at 10:13 AM, Amila Jayasekara wrote:

> Hi All,
> 
> Any particular reason why we have jglobus dependency [1] in following
> modules ?
> 
> modules/workflow-model/workflow-model-component
> modules/workflow-model/workflow-model-component-node
> modules/workflow-model/workflow-model-core
> modules/xbaya-gui
> modules/apache-airavata-client
> modules/apache-airavata-server
> modules/test-suite
> 
> I am in the process of getting rid of jglobus dependency from above
> modules. If you have any concerns please shout.
> 
> Thanks
> Amila
> 
> [1]
> <dependency>
>  <groupId>cog-jglobus</groupId>
>  <artifactId>cog-jglobus</artifactId>
>  <version>1.8.0_1</version>
> </dependency>


Mime
View raw message