airavata-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Raminderjeet Singh (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (AIRAVATA-770) Add Unicore provider to submit jobs
Date Tue, 26 Feb 2013 19:40:13 GMT

    [ https://issues.apache.org/jira/browse/AIRAVATA-770?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13587442#comment-13587442
] 

Raminderjeet Singh commented on AIRAVATA-770:
---------------------------------------------

I tried the patch and following are the challenges. 

1. BESProvider is dependent on cog-jglobus-1.8.0-bc146 which is not the released version of
JGlobus. GramProvider is dependent on cog-jglobus-1.8.0 and if i change the dependency to
bc146 version then the logs are not coming for GramProvider. Strange part is BESProvider logs
are fine. 

2. To test BESProvider, i left the build to use cog-jglobus-1.8.0-bc146,. 
a). There is a dependency on CA certificate. Shahbaz can you provide location to download
the CA certificate for Test and Juelich Unicore server.
b). After adding the CA cert, i am able to submit the job fine but the job failed. 
2013-02-26 07:07:28,066 [main] INFO  BESProvider  - Job https://zam1161v01.zam.kfa-juelich.de:8002/INTEROP1/services/BESActivity?res=1ec91f99-599c-4762-8cfb-30ed0b3cca71
is Failed. 
It would be great if the provider provide more details on the failure cause. 

3. I tried to remove the dependency on specific version of cog and use the released version.
I used  cog-jglobus-1.8.0 version. Doing that i am getting following error. I tried to add
dependency on released versions of bouncycastle but that did not help. Can you share the changes
made to cog? That will help us to discuss solution to solve version problem.  
Caused by: java.io.IOException: Can not load the PEM private key: java.io.IOException: Can
not load the PEM private key: no input data (empty source?)
    at eu.emi.security.authn.x509.impl.CertificateUtils.internalLoadPK(CertificateUtils.java:229)
    at eu.emi.security.authn.x509.impl.CertificateUtils.parsePEMPrivateKey(CertificateUtils.java:210)
    at eu.emi.security.authn.x509.impl.CertificateUtils.loadPEMKeystore(CertificateUtils.java:363)
    at eu.emi.security.authn.x509.impl.PEMCredential.<init>(PEMCredential.java:110)
    at eu.emi.security.authn.x509.impl.PEMCredential.<init>(PEMCredential.java:93)
    at org.apache.airavata.gfac.provider.impl.BESProvider.initSecurityProperties(BESProvider.java:201)
    ... 28 more

                
> Add Unicore provider to submit jobs
> -----------------------------------
>
>                 Key: AIRAVATA-770
>                 URL: https://issues.apache.org/jira/browse/AIRAVATA-770
>             Project: Airavata
>          Issue Type: Sub-task
>          Components: GFac
>    Affects Versions: 0.7
>            Reporter: Raminderjeet Singh
>            Assignee: Shahbaz Memon
>         Attachments: bes.patch, bes-spmd.patch-22-Feb
>
>


--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message