airavata-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Pedro da Silveira <pedro...@gmail.com>
Subject Two execution in one script.
Date Tue, 29 Jan 2013 20:48:34 GMT
Hi Dev,

I need a few tips here on how to run my workflow.

I prepared a simple script to run my workflow, which has 4 inputs and runs
on Lonestar.
In my script, I call two Fortran executable. It first runs "pw.x", later
runs "ph.x" in this order.
Unfortunately, as soon as the "pw.x" finishes, the ph.x does not start to
run. I checked the output and nothing is written there. By looking on Xbaya
dashboard it just says that my job is still running. My wall time is of 24h
because the ph.x will require  time to finish.
I am using the user name ogce on Lonestar.

Is this echo at end of my script correct?
Should I point to the path where my output is located?
Should I create a String Output variable on my AppService to receive this
information back on the Xbaya?

Script file name: executePhonon.sh

=================================================
#ibrun $SCRATCH/pw.x -inp ./Pwscf_Input > ./Pwscf_Output;
echo $*
export APP_PATH=/scratch/01437/ogce/Vlab/Phonon/

cd $APP_PATH
cp $1 .
cp $2 .
cp $3 .
cp $4 .
####ibrun
/scratch/01437/ogce/Vlab/pw.x < Pwscf_Input >> $APP_PATH/Pwscf_Output;

/scratch/01437/ogce/Vlab/ph.x < Phonon_Input >> $APP_PATH/Phonon_Output ;

echo Pwscf_Output=$APP_PATH/Pwscf_Output
echo Phonon_Output=$APP_PATH/Phonon_Output
===================================================

Any advice on how to have this script running on Lonestart is welcome.

Thank you,

Pedro da Silveira

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message