activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Justin Bertram <jbert...@apache.org>
Subject Re: ArtemisMQ Upgrade: How to determine if specific client version works with server version
Date Fri, 27 Aug 2021 17:38:56 GMT
There is no compatibility matrix as there is a concerted effort to maintain
backwards compatibility with older clients. Even when we make core protocol
changes older clients should still work, just without the new
functionality. If there is a breaking change for some reason it would be
called out in the documentation [1]. In short, it is generally safe to
assume that older clients will work unless otherwise noted.

A 2.15.0 client should work fine with a 2.18.0 broker.


Justin

[1]
https://activemq.apache.org/components/artemis/documentation/latest/versions.html

On Fri, Aug 27, 2021 at 8:39 AM foo bar <statuario186@gmail.com> wrote:

>  Hello,
>
> Is there some compatibility matrix we can use to determine if a specific
> client version will work with a specific server version? We are looking
> to upgrade from 2.15 to 2.18. We have looked at the release notes from 2.15
> to 2.18 and noted nothing about requiring a new client. Is it generally
> safe to assume that this would work unless otherwise noted in the release
> notes? We have a fairly substantial MQ deployment, it would be much easier
> to upgrade the server without having to upgrade all of the clients.
>
> Thanks
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message