activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Aaron Dutenhoefer <aar...@gmail.com>
Subject symmetric cluster UPD other than on 231.7.7.7:9876
Date Wed, 22 Apr 2020 02:46:35 GMT
I'm using Artemis ActiveMQ v2.11.0 currently - have been using it since 1.x
days.  I have three environments:  Integration, QA, and Production.  In
integration, I've got a standalone broker instance.  In QA I'm running a
two-node symmetric cluster using UDP discovery.  I followed the docs and
that worked fine.  In Production I'm trying to set up a four-node symmetric
cluster.

When I set up my first production cluster node, I started it up and it
immediately joined my QA cluster.  This was expected since the config still
was using 231.7.7.7:9876 as the discovery address/port.  (My Int/Qa/Prod
VMs are in the same datacenter/VLAN so UDP traffic routes across them)   I
then reconfigured the settings using another UDP address - Only to find the
other nodes configured using the new multicast/UDP address:port never
connect or discover each other.

I've double-and-triple-checked my configs and even tried using the examples
and updating my working QA cluster to use another multicast addr (like
231.7.7.8 for instance).  Any other address causes the cluster to lose
sight of all other nodes.  It really seems like you can't create a
symmetric artemis cluster that works except by using the 231.7.7.7:9876
config.

Has anyone else encountered this issue or ever tried to set up a simple
two-node test cluster using another discovery address/port besides
231.7.7.7 and gotten it to work?  Appreciate any suggestions anyone can
offer.

Thanks,

-a

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message