activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Justin Bertram <jbert...@apache.org>
Subject Re: H/A replication master slave
Date Mon, 24 Jun 2019 13:39:53 GMT
I don't really understand what you mean by, "If the only node to start is
the slave, i lose all information in the queue." Can you elaborate on this?
How are you losing information?


Justin

On Mon, Jun 24, 2019 at 8:37 AM galoi <g.aloi@tykelab.it> wrote:

> I'm using artemis ActiveMQ Artemis 2.9.0, and i configured two nodes master
> and slave in replication HA. View Below:
> <ha-policy>
>         <replication>
>                 <master>
>                         <check-for-live-server>true</check-for-live-server>
>                 </master>
>         </replication>
> </ha-policy>
>
> <ha-policy>
>         <replication>
>                 <slave>
>                         <allow-failback>true</allow-failback>
>                  </slave>
>         </replication>
> </ha-policy>
>
> When i stop the node master the slave to take the control.
> So far its ok, but when a stop too the slave, i have double point of
> failover.
> If the only node to start is the slave, i lose all information in the
> queue.
> How can i resolve it?
>
> Thanks in advance for the help!
>
> Kind regards,
> Gianfranco Aloi
>
>
>
> --
> Sent from:
> http://activemq.2283324.n4.nabble.com/ActiveMQ-User-f2341805.html
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message