activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Clebert Suconic <clebert.suco...@gmail.com>
Subject Re: Not receiving all messages when paging
Date Fri, 15 Mar 2019 20:09:09 GMT
Right. I suggested federation as it would always redistributed as long as
there are no consumers.

On Fri, Mar 15, 2019 at 3:21 PM Justin Bertram <jbertram@apache.org> wrote:

> It looks to me like your problem is just a misconfiguration. You haven't
> configured a redistribution-delay on your cluster-connection which means
> it's using the default of -1 which means messages will never be
> redistributed. If you set this to something >= 0 I believe you'll see the
> behavior you expect.
>
>
> Justin
>
> On Fri, Mar 15, 2019 at 2:15 PM artemisn00b <prahlad.misra@nokia.com>
> wrote:
>
> > "Federation has built in resilience to failure so if the target server
> > connection is lost, e.g. due to network failure, federation will retry
> > connecting to the target until it comes back online. When it comes back
> > online it will resume operation as normal."
> >
> >
> > How does that help in my situation? I don't want to be waiting
> indefinitely
> > for a broker to come up before it should start sending messages. Instead,
> > on
> > a broker failure, I want to switch over to an active one right away and
> > start forwarding messages to consumers. Similarly, on a broker failure,
> my
> > consumers also switch to a broker that is live and running.
> >
> >
> >
> > --
> > Sent from:
> > http://activemq.2283324.n4.nabble.com/ActiveMQ-User-f2341805.html
> >
>
-- 
Clebert Suconic

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message