activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Tim Bain <tb...@alumni.duke.edu>
Subject Re: Unwanted (unsolicited) messages from ActiveMQ.Advisory.MasterBroker
Date Mon, 18 Feb 2019 13:45:14 GMT
So wait, I understood you to say that the problem was the trailing .> on
the name of your topicName element, but in the working example
configuration you gave, the trailing .> is still there. What did I
misunderstand?

Tim

On Thu, Feb 7, 2019, 8:21 AM emw <enrico.maschietto.work@gmail.com wrote:

> I did some tests and outcome is that it is neither a matter of point 1) nor
> point 2).
> The issue arises when listening queue when ends with .>
> I changed my topics and queues namespace and now I'm not getting advisory
> message anymore.
> Moreover I noted that in the activemq webconsole when advisory message is
> sent
> the 'Number Of Pending Messages' is -1!!!
>
> At this point do think an issues must be submitted?
>
> --
> My new working configuration is (note that I changes prefix into cloud. but
> again it is not a matter of preifx but a matter of .> at the end of
> listening queue):
> listener listens to cloud.mqtt.*.values
> and activemq.xml is
> <destinationInterceptors>
>  <virtualDestinationInterceptor>
>    <virtualDestinations>
>       <virtualTopic name="mqtt.>" prefix="cloud." selectorAware="false"/>
>    </virtualDestinations>
>  </virtualDestinationInterceptor>
> </destinationInterceptors>
>
>
>
>
> --
> Sent from:
> http://activemq.2283324.n4.nabble.com/ActiveMQ-User-f2341805.html
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message