activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Chinman01 <gmangreatn...@gmail.com>
Subject Cannot add custom transport
Date Thu, 07 Feb 2019 15:27:35 GMT
I've been struggling with adding a new transport on ActiveMQ.

I compiled a jar with my transport (ModifiedSSLTransport) and
transportfactory (ModifiedAMQPSSLTransportFactory) and added on /lib a file
called amqpFil with contents "class=ModifiedAMQPSSLTransportFactory".

I annexed my activemq.xml file, but the relevant part is the following:
"<transportConnector name="amqpFil"
uri="amqpFil://localhost:5673?trace=true&amp;needClientAuth=true"/>"

I get this error: "Transport Connector could not be registered in JMX:
java.io.IOException: Transport scheme NOT recognized: [amqpFil]".

I think I'm not putting the amqpFil file on the correct place, but have no
idea where I should put it. I tried putting it on the META-INF.services
folder on the compiled jar, I have extracted the AMQP jar, put it on its
META-INF.services and re-compressed it and I always get the same error.

Where should the amqpFil file go? What am I doing wrong?
Thanks!



--
Sent from: http://activemq.2283324.n4.nabble.com/ActiveMQ-User-f2341805.html

Mime
View raw message