activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Justin Bertram <jbert...@apache.org>
Subject Re: Artemis. Qos2 on subscription.
Date Thu, 20 Dec 2018 19:45:34 GMT
Are there any errors logged on the broker? This looks like it might be a
client problem or some kind of network issue.

Do you have a test to reproduce this failure?


Justin

On Tue, Nov 20, 2018 at 11:34 AM itorres <itorres@karisra.info> wrote:

> Hello,
>
> We use MQTT to connect to an Apache Artemis 2.6.3 server. We want to be
> subscribed on qos2 in order to be aware of the messages only once. Also, we
> want to publish in qos2 in order to be sure that the message will arrive
> only once.
>
> However, after subscribing to a topic in qos2, and publishing to the same
> topic on qos2, we get disconnected with the following error :
>
>
> 2018-11-12 14:23:21,941 ERROR --- MqttFX ClientModel             : Error
> publishing to topic: app/test
> org.eclipse.paho.client.mqttv3.MqttException: Connection lost
>         at
>
> org.eclipse.paho.client.mqttv3.internal.CommsReceiver.run(CommsReceiver.java:181)
> ~[org.eclipse.paho.client.mqttv3-1.2.0.jar:?]
>         at
> java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:511)
> ~[?:1.8.0_162]
>         at java.util.concurrent.FutureTask.run(FutureTask.java:266)
> ~[?:1.8.0_162]
>         at
>
> java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.access$201(ScheduledThreadPoolExecutor.java:180)
> ~[?:1.8.0_162]
>         at
>
> java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.run(ScheduledThreadPoolExecutor.java:293)
> ~[?:1.8.0_162]
>         at
>
> java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1149)
> ~[?:1.8.0_162]
>         at
>
> java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:624)
> ~[?:1.8.0_162]
>         at java.lang.Thread.run(Thread.java:748) ~[?:1.8.0_162]
> Caused by: java.io.EOFException
>         at java.io.DataInputStream.readByte(DataInputStream.java:267)
> ~[?:1.8.0_162]
>         at
>
> org.eclipse.paho.client.mqttv3.internal.wire.MqttInputStream.readMqttWireMessage(MqttInputStream.java:92)
> ~[org.eclipse.paho.client.mqttv3-1.2.0.jar:?]
>         at
>
> org.eclipse.paho.client.mqttv3.internal.CommsReceiver.run(CommsReceiver.java:133)
> ~[org.eclipse.paho.client.mqttv3-1.2.0.jar:?]
>         ... 7 more
>
> Do you have any idea about that problem and how to resolve it ?
>
> Thanks in advance,
>
> Regards.
>
>
>
> --
> Sent from:
> http://activemq.2283324.n4.nabble.com/ActiveMQ-User-f2341805.html
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message