activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Tim Bain <tb...@alumni.duke.edu>
Subject Re: Older Message Not Consumed(Stay Untouched in queue) Newer Messages consumed
Date Mon, 26 Mar 2018 05:17:01 GMT
Do the consumers on that queue use selectors? If so, is it possible that
the selectors for all active consumers simply don't match those messages?

Does the problem persist after you restart the broker? Or are all messages
consumed once the process is restarted? In earlier versions there were some
problems where messages would not get dispatched due to a bug but would be
handled correctly after a restart, though my memory is that those problems
were primarily in the 5.8-5.10 timeframe and I don't remember having seen
reports of them in the more recent versions.

Delayed/scheduled messages wouldn't show up in the web console until their
scheduled time has arrived, so I don't think that's relevant to the
behavior you're seeing.

Tim

On Thu, Mar 22, 2018 at 5:28 AM, ajayvaghelanw <ajay.vaghela@netweb.biz>
wrote:

> Hello,
>
> I am using ActiveMQ 5.15.0 and there are multiple queues in system which
> helps to communicate my system for each queue there is an individual
> system.
>
> But, sometimes in a queue multiple messages of any random time period got
> stuck but after that time period newer messages is consumed but older
> remained in queue.
>
> I have added delay configuration in ActiveMQ. (Is it the reason??)
>
> I have tried to identify the cause but not come to any conclusion.
>
> I have seen that ActiveMQ has similar kind of problem in version older than
> 5.9.
>
>
> Please help me out.
>
> <http://activemq.2283324.n4.nabble.com/file/t378986/queueMessages.png>
>
>
>
> --
> Sent from: http://activemq.2283324.n4.nabble.com/ActiveMQ-User-
> f2341805.html
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message