activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Rajesh Malla <mallara...@gmail.com>
Subject Re: Camel generating message with correlationid=null and tmp-queue null
Date Sun, 18 Mar 2018 15:14:12 GMT
>Is your client using a failover transport? If so, it's the failover 
>transport that's re-establishing the connection. 

we are not using any failover transport

I see you're using the https transport. Does it work if you connect with 
the tcp transport instead? It's possible that there's some bug in the https 
transport, so if you find that clients can connect with tcp but not with 
https, that would be useful information to know.. ??

We have to use https only, because our server broker sits in cloud &
onpremises in another location. via some other url authenticating. this
scenario is working properly in  <5.8.0
 of activemq  however not working with 5.12.3 version. I mean, for some
hours it is working after that it is giving errors like attached :
error.txt <http://activemq.2283324.n4.nabble.com/file/t378915/error.txt>  

we are using service mix [ activemq 5.12.3 & camel 2.16.2 & spring 3.2 ].

one more question : when we are making route using camel we are seeing many
consumers are started.
for spring DMLC we are providing default cachel level CACHE_NONE. for one
route why it is creating nearly 8 to 9 consumers on same queue. because of
above errors each consumer is closed I think, finally nothing is working.

https option we cannot change it now, bcz of our designs, what is the main
reason we are not able to receive message ? 

also remove connection and create connection means, we are removing
component in camel and creating new route in camel on that queue. even if we
restart client also wroking.





--
Sent from: http://activemq.2283324.n4.nabble.com/ActiveMQ-User-f2341805.html

Mime
View raw message