activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Tim Bain <tb...@alumni.duke.edu>
Subject Re: Message Dequeued count increases by a lot after a message is failed to send to a subscriber
Date Fri, 02 Feb 2018 13:59:36 GMT
That sounds like a bug.

What version of ActiveMQ are you using? If it's anything before 5.14.x, can
you please try a newer version (5.15.2, ideally) to confirm that it still
occurs in a current version?

Thanks,
Tim

On Feb 1, 2018 11:23 AM, "kj" <nonprofessionalaccount@outlook.com> wrote:

> This is the story:
>
> I am testing whether messages are sent to the DLQ if a subscriber has
> failed
> to receive a message.
>
> I start off with the following settings.
>
> Topic = topic1
> Messages Enqueued = 0
> Messages Dequeued = 0
> Number of subscribers to topic1 = 1
> Retry policy count = 0
>
> I post a message to topic1 using the ActiveMQ web console. The subscriber
> receives the message as expected and it throws a runtime exception as
> expected. I except the message to be sent to the DLQ and that happens as
> expected. After this all happens I check the number of messages enqueued
> and
> it says 1, which is expected. I check the number of messages dequeued and
> it
> says 2, which is what I don't understand. I'm under the assumption that it
> should say 1.
>
> Could someone please clarify whether why the count is 2?
>
> Thank You
>
>
>
> --
> Sent from: http://activemq.2283324.n4.nabble.com/ActiveMQ-User-
> f2341805.html
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message