activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Tim Bain <tb...@alumni.duke.edu>
Subject Re: Consumers hanging on a queue although there are messages in it
Date Mon, 22 Jan 2018 21:18:18 GMT
Are any selectors in use on the consumers of the queue that's getting
"blocked"? If so, are there any messages published that don't match any of
the selectors?

If you take a thread dump on the broker, where do you see threads waiting?

Can you reproduce this on demand in a test environment with a minimum setup
(one queue, one or two consumers, a known, repeatable set of messages), or
is this the type of problem that only occurs in ops after weeks or months
of heavy usage? Hopefully it's the former, because the latter problem is
usually very hard to diagnose.

Tim

On Jan 22, 2018 4:56 AM, "Stefanic" <snicodem@movingintelligence.com> wrote:

> Haris wrote
> > Here is something more, really weird: Almost always, the following dirty
> > hack "unblocked" the consumers: refreshing the queue browser page, i.e.
> > http://localhost:8161/admin/queues.jsp
>
> Hi Haris,
>
> Did you ever find out what caused this behavior?
>
> We recently upgraded both the ActiveMQ server and the ActiveMQ (and Camel)
> client library and this problem has suddenly popped up for the first time..
>
> We went from ActiveMQ server 5.11.1 to 5.15.2 and client library 5.12.2 to
> 5.15.2.
>
> It does look like a problem in the server because restarting the client
> results in the exact same behavior, and when opening the queue browser it
> is
> resolved immediately.
>
>
>
> --
> Sent from: http://activemq.2283324.n4.nabble.com/ActiveMQ-User-
> f2341805.html
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message