activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Raul Valdoleiros <raul.valdoleiros.olive...@gmail.com>
Subject Artemis Connection failure has been detected
Date Thu, 25 Jan 2018 17:34:11 GMT
Hi,

I'm trying to create a dynamic cluster of artemis brokers. I'm getting the
following messages when I shutdown one of the brokers.

17:24:47,747 WARN  [org.apache.activemq.artemis.core.client] AMQ212037:
Connection failure has been detected: AMQ119015: The connection was
disconnected because of server shutdown [code=DISCONNECTED]
17:24:47,763 WARN  [org.apache.activemq.artemis.core.client] AMQ212037:
Connection failure has been detected: AMQ119015: The connection was
disconnected because of server shutdown [code=DISCONNECTED]
17:24:47,755 WARN  [org.apache.activemq.artemis.core.client] AMQ212037:
Connection failure has been detected: AMQ119015: The connection was
disconnected because of server shutdown [code=DISCONNECTED]
17:24:47,769 WARN  [org.apache.activemq.artemis.core.server] AMQ222095:
Connection failed with failedOver=false
17:24:47,797 WARN  [org.apache.activemq.artemis.core.server] AMQ222095:
Connection failed with failedOver=false
17:24:47,801 INFO  [org.apache.activemq.artemis.core.server] AMQ221029:
stopped bridge
$.artemis.internal.sf.my-cluster.23bc5035-d11d-11e7-b017-8c705a641428
17:24:57,973 WARN  [org.apache.activemq.artemis.core.client] AMQ212034:
There are more than one servers on the network broadcasting the same node
id. You will see this message exactly once (per node) if a node is
restarted, in which case it can be safely ignored. But if it is logged
continuously it means you really do have more than one node on the same
network active concurrently with the same node id. This could occur if you
have a backup node active at the same time as its live node.
nodeID=23bc5035-d11d-11e7-b017-8c705a641428

I suspect that this behavior makes the brokers lost messages.

I attached the brokers configurations. Can someone help me understand what
is wrong?

Thanks in advance,
Raul

Mime
  • Unnamed multipart/mixed (inline, None, 0 bytes)
View raw message