activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Tim Bain <tb...@alumni.duke.edu>
Subject Re: Could not reserve enough space for object heap
Date Wed, 06 Dec 2017 05:00:06 GMT
There are a number of possible explanations laid out in
https://stackoverflow.com/questions/4401396/could-not-reserve-enough-space-for-object-heap,
the first Google search result when searching for that error message. Do
any of them, or any of the other search results for that error, explain the
behavior you're seeing? If not, you might want to tell us more about the
version of Java that you're running and the memory profile of the machine
at the time you try to run.

I'll also say from personal experience that in 32-bit Windows I've seen
situations where I couldn't get enough contiguous memory to launch the JVM
till I closed other running programs (frequently Microsoft programs) that
preferred to run at fixed memory addresses that broke up the available
contiguous memory. Outlook was a prime offender, though I also saw problems
with Lotus Sametime. Closing the program, launching Java, and then
relaunching the program usually solved the problem.

Tim

On Dec 4, 2017 1:11 PM, "shaneduncan85" <shane@subnet-solutions.com> wrote:

>  I am new to ActiveMQ, when I run bin\activemq I am receiving this error
> "Could not reserve enough space for 1048576kb object heap". I am attempting
> to launch the ActiveMQ service on a Windows 2008 SP1 server.  Any thought
> on
> how to resolve would be appreciated.
>
>
>
> --
> Sent from: http://activemq.2283324.n4.nabble.com/ActiveMQ-User-
> f2341805.html
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message