activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Justin Bertram <jbert...@redhat.com>
Subject Re: [Artemis] Invalid keys during XA Recovery from HornetQ client
Date Fri, 17 Nov 2017 15:28:01 GMT
I'd try using the Artemis JCA RA.  You can build it using the
<ARTEMIS_HOME>/examples/features/sub-modules/artemis-ra-rar example shipped
with the broker.


Justin

On Fri, Nov 17, 2017 at 9:14 AM, Benjamin Buehlmann <
benjamin.buehlmann@gmail.com> wrote:

> I configured a ActiveMQ Artemis 2.4.0 HA setup with replication and a
> static
> cluster connection of the two nodes (live- and backup node). As one of the
> test clients I use a JBoss EAP 6.3.2 with embedded HornetQ.
>
> Every two minutes a see a Warning in the clients log that some keys are not
> know by the client side HornetQ ClientSessionFactoryImpl. Please find below
> the stacktrace and the configuration of the broker and client.
>
> Can I fix somehow this behaviour? Or do I need to integrate the Artemis
> resource adapter on the JBoss instances?
>
>
> Warning on client side appears every 2 Minutes (recovery interval):
>
>
>
> Configuration of broker (Artemis 2.4.0)
> ==================================
>
>
>
> Configuration of client (JBoss EAP 6.3.2):
> ==================================
>
>
>
>
>
> --
> Sent from: http://activemq.2283324.n4.nabble.com/ActiveMQ-User-
> f2341805.html
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message