activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Tim Bain <tb...@alumni.duke.edu>
Subject Re: [ActiveMQ-CPP] "backup=true" does not work with failover transport
Date Tue, 01 Aug 2017 12:29:51 GMT
Unfortunately there's not a mechanism for that type of graceful transition
off of a broker.

Tim

On Aug 1, 2017 3:16 AM, "Tamas1" <tamas.reinhardt@i-new.com> wrote:

> Thank you for your answer. Having no other option, I have used it with
> "backup=false".
>
> I use two ActiveMQ servers in network of brokers setup for realtime, non
> persistent messaging. Throughput is up to several thousands of messages /
> second on a couple of queues parallel. If it worked, I would be interested
> in to see if "backup=true" causes a significant decrease in the time of
> failover.
>
> ---
>
> Loosely related topic: When I shut down the "primary" broker, messages in
> the queues (which are in memory) are obviously lost. (Persistent messaging
> doesn't make sense because of a very low "TTL".) Is there any way to get
> (or
> trigger) producers to reconnect to the "secondary" (or backup) broker
> before
> the "primary" broker shuts down? If there is no producing on the "to be
> shut
> down broker" and remaining messages are consumed before the shutdown then
> the failover would not cause messages to be lost.
>
>
>
> --
> View this message in context: http://activemq.2283324.n4.
> nabble.com/ActiveMQ-CPP-backup-true-does-not-work-with-failover-transport-
> tp4728967p4729101.html
> Sent from the ActiveMQ - User mailing list archive at Nabble.com.
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message