activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Clebert Suconic <clebert.suco...@gmail.com>
Subject Re: [Fixed] Programatically setting up a proxying broker
Date Fri, 04 Aug 2017 13:34:55 GMT
Oh.. duh... apologize... I misread this through the iPhone yesterday..
I thought it was referring to Proxy to the connections:

https://github.com/apache/activemq-artemis/pull/1293

On Fri, Aug 4, 2017 at 9:08 AM, Tim Bain <tbain@alumni.duke.edu> wrote:
> Clebert, which feature were you referring to?
>
> On Aug 3, 2017 9:44 PM, "Clebert Suconic" <clebert.suconic@gmail.com> wrote:
>
>> There is a pending pull request in activemq artemis to add that feature.
>>
>> On Thu, Aug 3, 2017 at 11:51 AM Mark Raynsford <
>> list+org.apache.activemq@io7m.com> wrote:
>>
>> > On 2017-08-03T08:57:38 -0600
>> > Tim Bain <tbain@alumni.duke.edu> wrote:
>> > >
>> > > My question was why you needed to subclass it in the first place.
>> >
>> > Ah, that was down to an error in thinking on my part when looking at
>> > the available network connectors. It went something like this: "Hm, need
>> > a NetworkConnector. Don't seem to need 'discovery', don't seem to need
>> > 'multicast', don't seem to need LDAP... Guess I'm supposed to provide
>> > my own subclass". I only realized my mistake when I tracked down which
>> > subclass is instantiated for the broker when running the binary
>> > distribution from the command line (DiscoveryNetworkConnector).
>> >
>> > --
>> > Mark Raynsford | http://www.io7m.com
>> >
>> --
>> Clebert Suconic
>>



-- 
Clebert Suconic

Mime
View raw message