activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Justin Bertram <jbert...@redhat.com>
Subject Re: Artemis 2.2.0, createTopic create an anycast when there is no consumer created
Date Fri, 04 Aug 2017 17:40:14 GMT
> Is there a way to retrieve the message sent to the topic before receiver
registered to the topic?

No.  This is basic publish-subscribe semantics.  Only messages published
after the subscription is created are received.

Pre-creating the address with the desired routing-type is a work-around.  I
still think this is a bug.


Justin

On Fri, Aug 4, 2017 at 12:26 PM, vchen1 <yuhua_98@yahoo.com> wrote:

> Further more, I have tested the following case:
> I pre-configured a topic in broker.xml:
>
> <address name="preDefTopic">
>             <multicast/>
> </address>
>
>
> And test the same sequence as I described earlier:
> 1.) Start sender program first and send a message, and then start receiver.
> There is a multicast queue created after I started receiver. However, I
> couldn't located the message I send to the topic. The message count on the
> newly created multicast queue is 0. Is there a way to retrieve the message
> sent to the topic before receiver registered to the topic?
>
> 2.) Start receiver first and then start sender, now the message received
> successfully.
>
> Thanks,
>
>
>
> --
> View this message in context: http://activemq.2283324.n4.
> nabble.com/Artemis-2-2-0-createTopic-create-an-anycast-
> when-there-is-no-consumer-created-tp4729269p4729273.html
> Sent from the ActiveMQ - User mailing list archive at Nabble.com.
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message