activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From vdmitriev <allat...@gmail.com>
Subject Re: AMQ 5.11.1, NPE in KahaAddMessageCommand.getMessage() (JIT suspected)
Date Wed, 02 Aug 2017 23:05:30 GMT
Hi, Tim!

> I'm not aware of any runtime modification of the compiled sources, and
> I've
> never encountered anything that looked like it when attaching with a
> debugger, but please post your question to the dev list to be sure.

Ok, done.

> BTW, I've experienced a similar "impossible" exception under Oracle
> Hotspot
> 8u21 that was caused by a JIT bug, so those things do occasionally happen.
> Have you tried swapping out your JRE to see if that eliminates the
> problem?
> I'd switch to a non-IBM JRE just to have the best odds of not hitting the
> same bug in the new JRE.

I'm now aware of any JVM which is compatible with AIX OS other than IBM.
Anyway, customer has nightmarish bureaucratic procedure to update anything
on production environment, so I'm stuck with AMQ 5.11.1 and 3 years old JVM
for the foreseeable future. Unless I provide significant reason to make
changes. And I really count on encountering JIT compiler issue now to force
JVM upgrade.

Thanks for sharing your ideas!

~Regards
Vadim



--
View this message in context: http://activemq.2283324.n4.nabble.com/AMQ-5-11-1-NPE-in-KahaAddMessageCommand-getMessage-JIT-suspected-tp4729109p4729198.html
Sent from the ActiveMQ - User mailing list archive at Nabble.com.

Mime
View raw message