activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Tim Bain <tb...@alumni.duke.edu>
Subject Re: upgrade activemq from 5.6 to 5.9
Date Thu, 06 Jul 2017 01:43:43 GMT
Have you tried removing your dependency on 1.38 and depending only on 1.47?
If that works, it seems like the simplest solution.

Tim

On Jul 5, 2017 4:09 PM, "devworkslogin" <devworkslogin@hotmail.com> wrote:

> Hello, I am trying to upgrade from activemq 5.6 to 5.9 or later with
> embedded
> activemq broker.
>
> When upgraded to 5.9 and our application starts, any https request fails
> with the following error:
>
> Could not generate DH keypair; nested exception is
> javax.net.ssl.SSLException: java.lang.RuntimeException: Could not generate
> DH keypair
>  at
> org.springframework.web.client.RestTemplate.doExecute(
> RestTemplate.java:607)
>  at
> org.springframework.web.client.RestTemplate.execute(RestTemplate.java:565)
>
> Caused by: java.security.InvalidAlgorithmParameterException: parameter
> object not a ECParameterSpec
>         at
> org.bouncycastle.jce.provider.JDKKeyPairGenerator$EC.initialize(Unknown
> Source)
>         at sun.security.ssl.ECDHCrypt.<init>(ECDHCrypt.java:77)
>
>
> Although it doesn't look anyway related to ActiveMQ, it does look like an
> older version of bouncy castle is being loaded. (We do have
> bc-prov-1.38.jar
> in the classpath)
>
> I looked around to found that activemq 5.8 onwards, there is transitive
> dependency on bc-1.47.
>
> Any recommendations on how to resolve this dependency issue? Is this an
> issue only with activemq 5.9 and bouncy castle or is there some other
> dependency issue that is not evident?
>
>
>
>
>
>
>
> --
> View this message in context: http://activemq.2283324.n4.
> nabble.com/upgrade-activemq-from-5-6-to-5-9-tp4728235.html
> Sent from the ActiveMQ - User mailing list archive at Nabble.com.
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message